码迷,mamicode.com
首页 > 其他好文 > 详细

HDU2680 Choose the best route 【Dijkstra】

时间:2014-08-13 22:34:27      阅读:312      评论:0      收藏:0      [点我收藏+]

标签:hdu2680

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7061    Accepted Submission(s): 2300


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
 

Author
dandelion

题意:给定m条有向边,问从某些点到终点能否到达,若能则输出最短距离否则输出-1.
题解:开始用Floyd超时,换成Dijkstra就过了。


#include <stdio.h>
#include <string.h>
#define maxn 1010
#define maxm 20010
#define inf 0x3f3f3f3f

int map[maxn][maxn];
int dist[maxn];
bool vis[maxn];

int getNext(int n)
{
	int u = -1, tmp = inf, i;
	for(i = 1; i <= n; ++i)
		if(!vis[i] && dist[i] < tmp){
			tmp = dist[i]; u = i;
		}
	return u;
}

void Dijkstra(int n, int s)
{
	int i, u, v, tmp;
	for(i = 0; i <= n; ++i){
		vis[i] = false; dist[i] = inf;
	}
	u = 0; dist[0] = 0;
	while(u != -1){
		for(i = 0; i <= n; ++i){
			tmp = dist[u] + map[u][i];
			if(tmp < dist[i]) dist[i] = tmp;
		}
		vis[u] = true;
		if(vis[s]) return;
		u = getNext(n);
	}
}

int main()
{
	int n, m, s, w, i, u, v, c;
	while(scanf("%d%d%d", &n, &m, &s) == 3){
		memset(map, 0x3f, sizeof(map));
		for(i = 0; i < m; ++i){
			scanf("%d%d%d", &u, &v, &c);
			if(map[u][v] > c) map[u][v] = c;
		}
		scanf("%d", &w);
		while(w--){
			scanf("%d", &u);
			map[0][u] = 0;
		}
		Dijkstra(n, s);
		printf("%d\n", dist[s] == inf ? -1 : dist[s]);
	}
	return 0;
}


HDU2680 Choose the best route 【Dijkstra】,布布扣,bubuko.com

HDU2680 Choose the best route 【Dijkstra】

标签:hdu2680

原文地址:http://blog.csdn.net/chang_mu/article/details/38541827

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!