标签:hdu1312
Red and Black
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9732 Accepted Submission(s): 6060
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move
only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
#include <stdio.h>
#include <string.h>
#define maxn 22
int n, m, ans;
const int mov[][2] = {1, 0, -1, 0, 0, 1, 0, -1};
char map[maxn][maxn];
bool check(int x, int y){
return x >= 0 && y >= 0 &&
x < n && y < m && map[x][y] != '#';
}
void DFS(int x, int y)
{
int a, b, i;
for(i = 0; i < 4; ++i){
a = x + mov[i][0];
b = y + mov[i][1];
if(check(a, b)){
++ans; map[a][b] = '#';
DFS(a, b);
}
}
}
int main()
{
int i, j, x, y;
while(scanf("%d%d", &m, &n) == 2 && (m || n)){
for(i = 0; i < n; ++i){
getchar();
for(j = 0; j < m; ++j){
map[i][j] = getchar();
if(map[i][j] == '@'){
x = i; y = j;
}
}
}
map[x][y] = '#';
ans = 1; DFS(x, y);
printf("%d\n", ans);
}
return 0;
}
HDU1312 Red and Black,布布扣,bubuko.com
HDU1312 Red and Black
标签:hdu1312
原文地址:http://blog.csdn.net/chang_mu/article/details/38541019