码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3414--Pots--BFS+回溯路径

时间:2014-08-14 01:33:57      阅读:253      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   for   ar   

Pots
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9963   Accepted: 4179   Special Judge

Description

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input

3 5 4

Sample Output

6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)


和之前做过的一道二维bfs一样,只不过这个需要回溯路径,很简单在结构体中加一个变量来记录上一个状态在队列中的下标(手敲的队列比较好,这个时候在用STL队列好像不大方便)最后找到满足条件的状态逆向打印路径(因为记录的都是上一个状态)
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <queue>
using namespace std;
int m,n,c,s,e,p;
typedef struct node
{
	int v1,v2,cur,pre,op;
};
bool vis[999][999];
int ans[10010];
node que[10010];
void bfs()
{
	p=0;s=0;e=0;int pos;
	node t={0,0,0,0,0};
	que[e++]=t;
	vis[0][0]=1;
	while(s<e)
	{
		node f=que[s];pos=s;s++;
		if(f.v1==c||f.v2==c)
		{
			printf("%d\n",f.op);
			int tem=pos;
			for(int i=0;i<f.op;i++)
			{
               ans[p++]=que[tem].cur;
               tem=que[tem].pre;
			}
			for(int i=p-1;i>=0;i--)
			{
				switch(ans[i])
				{
					case 1:printf("FILL(1)\n");break;
					case 2:printf("FILL(2)\n");break;
					case 3:printf("DROP(1)\n");break;
					case 4:printf("DROP(2)\n");break;
					case 5:printf("POUR(2,1)\n");break;
					case 6:printf("POUR(1,2)\n");break;
				}
			}
			return ;
		}
		if(f.v1!=m)
		{
			t.v1=m;
			t.op=f.op+1;
			t.v2=f.v2;
			if(!vis[t.v1][t.v2])
			{
			 vis[t.v1][t.v2]=1;
			 t.cur=1;
			 t.pre=pos;
			 que[e++]=t;
			}
		}
		if(f.v2!=n)
		{
			t.v2=n;
			t.op=f.op+1;
			t.v1=f.v1;
			if(!vis[t.v1][t.v2])
			{
			 vis[t.v1][t.v2]=1;
			 t.cur=2;
			t.pre=pos;
			 que[e++]=t;
			}
		}
		if(f.v1!=0)
		{
			t.v1=0;
			t.v2=f.v2;
			t.op=f.op+1;
			if(!vis[t.v1][t.v2])
			{
			 vis[t.v1][t.v2]=1;
			 t.cur=3;
			 t.pre=pos;
			 que[e++]=t;
			}
		}
		if(f.v2!=0)
		{
			t.v2=0;
			t.v1=f.v1;
			t.op=f.op+1;
			if(!vis[t.v1][t.v2])
			{
			 vis[t.v1][t.v2]=1;
			 t.cur=4;
			 t.pre=pos;
			 que[e++]=t;
			}
		}
		if(f.v2!=0&&f.v1!=m)
		{
			t.v2=f.v2-(m-f.v1);if(t.v2<0) t.v2=0;
			t.v1=f.v1+f.v2;  if(t.v1>m) t.v1=m;
			t.op=f.op+1;
			if(!vis[t.v1][t.v2])
			{
			 vis[t.v1][t.v2]=1;
			 t.cur=5;
			 t.pre=pos;
			 que[e++]=t;
			}
		}
		if(f.v1!=0&&f.v2!=n)
		{
			t.v1=f.v1-(n-f.v2);if(t.v1<0) t.v1=0;
			t.v2=f.v2+f.v1;  if(t.v2>n) t.v2=n;
			t.op=f.op+1;
			if(!vis[t.v1][t.v2])
			{
			 vis[t.v1][t.v2]=1;
			 t.cur=6;
			 t.pre=pos;
			 que[e++]=t;
			}
		}
	}
	puts("impossible");
}
int main()
{
	while(cin>>m>>n>>c)
	{
		memset(vis,0,sizeof(vis));
		bfs();
	}
	return 0;
}


POJ 3414--Pots--BFS+回溯路径,布布扣,bubuko.com

POJ 3414--Pots--BFS+回溯路径

标签:des   style   color   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/qq_16255321/article/details/38546341

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!