码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3054 Fibonacci 找循环节的公式题

时间:2016-10-27 23:14:17      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:ane   others   space   define   other   namespace   can   main   sample   

Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)


Problem Description
We know the Fibonacci Sequence

F1=1,F2=1,F3=2,F4=3,F5=5,

...

Fx = Fx-1+Fx-2

We want to know the Mth number which has K consecutive "0" at the end of Fx.

For example,

F15=610

It is the first number which has only one "0" at the end.

F300=222232244629420445529739893461909967206666939096499764990979600.

It is the second number which has two "0" at the end.

Of course, the Fx may be very large if M and K are big. So we only want to know the subscript of Fx (it means the "x" For a given M and K)
 

 

Input
Input includes multiple cases.

First line is the number of case x

The next x lines: Each line contains two integer number, K and M, divided by a space.
 

 

Output
For each case:

Print a integer number in a line, is the Mth number which has K consecutive 0s at the end of Fx. (You can believe the answer is smaller than 2^31);
 

 

Sample Input
3 1 1 2 2 2 5
 

 

Sample Output
15 300 900
 

 

Source
#include<bits/stdc++.h>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
const int N=2e5+10,M=4e6+10,inf=1e9+10,MOD=1000;
const ll INF=1e18+10;
int a[100]={1,15,150,750,7500,75000,750000,7500000,75000000,750000000};
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int k,m;
        scanf("%d%d",&k,&m);
        if(k==2)
            printf("%d\n",((m-1)/4*5+1)*a[k]+((m-1)%4)*a[k]);
        else
            printf("%d\n",((m-1)/9*10+1)*a[k]+((m-1)%9)*a[k]);
    }
    return 0;
}

 

hdu 3054 Fibonacci 找循环节的公式题

标签:ane   others   space   define   other   namespace   can   main   sample   

原文地址:http://www.cnblogs.com/jhz033/p/6005689.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!