码迷,mamicode.com
首页 > 其他好文 > 详细

Billboard

时间:2016-10-28 23:30:50      阅读:623      评论:0      收藏:0      [点我收藏+]

标签:source   return   mis   oss   paper   sts   ace   roo   puts   

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 20145    Accepted Submission(s): 8391


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that‘s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can‘t be put on the billboard, output "-1" for this announcement.
 

 

Sample Input
3 5 5 2 4 3 3 3
 

 

Sample Output
1 2 1 3 -1
 

 

Author
hhanger@zju
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1698 1542 1394 1828 1540 
#include<bits/stdc++.h>
using namespace std;
#define N 200005
#define lson i*2, l, m
#define rson i*2+1, m+1, r
int sum[N*4];///存放节点
int W,H,Q;
void pushup(int i)
{
    sum[i]=max(sum[i*2],sum[i*2+1]);
}
void built(int i,int l,int r)
{
    if(l==r)
    {
        sum[i]=W;
        //cout<<sum[i]<<" ";
        return;
    }
    int m=(l+r)/2;
    built(lson);
    built(rson);
    pushup(i);
}
int update(int w,int i,int l,int r)
{

    //cout<<"w="<<w<<endl;
    if(w>sum[i])
    {
        //cout<<"sum[i]="<<sum[i]<<" w="<<w<<endl;
        return -1;
    }
    if(l==r)
    {
        //cout<<"l="<<l<<endl;
        sum[i]-=w;
        return l;
    }
    int m=(l+r)/2;
    int cur=-1;
    if(w<=sum[i*2])///优先选上面的位置
        cur=update(w,lson);
    else if(w<=sum[i*2+1])///没有的话选下面的
        cur=update(w,rson);
    pushup(i);
    return cur;
}
int main()
{
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    while(scanf("%d%d%d",&H,&W,&Q)!=EOF)
    {
        int n=min(H,Q);
        built(1,1,n);
        int op;
        for(int i=1;i<=Q;i++)
        {
            scanf("%d",&op);
            printf("%d\n",update(op,1,1,n));
        }
    }
    return 0;
}

 

Billboard

标签:source   return   mis   oss   paper   sts   ace   roo   puts   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/6009431.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!