码迷,mamicode.com
首页 > 其他好文 > 详细

1046

时间:2014-05-08 06:25:24      阅读:421      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

bubuko.com,布布扣
Gridland

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4127    Accepted Submission(s): 1900


Problem Description
For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the “easy” problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the “hard” ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.

The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North–South or East–West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 × 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 × 3-Gridland, the shortest tour has length 6. 


 

Input
The first line contains the number of scenarios.

For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.
 

Output
The output for each scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.
 

Sample Input
2
2 2
2 3
 

Sample Output
Scenario #1:
4.00

Scenario #2:
6.00
 
bubuko.com,布布扣
bubuko.com,布布扣
#include<iostream>
#include<stdio.h>
#include<cmath>
#include<algorithm>
using namespace std;
int cmp(int a,int b)
{
    return a<b;
    
}
int main()
{
    int i,j,m,n,cas;
    float len;
    int a[2];
    cin>>n;
    cas=0;
    while(n--)
    {
        cin>>a[0]>>a[1];
        sort(a,a+2,cmp);
        if(a[0]==1)
        len=a[1]-1;
        if(a[0]==2)
        len=a[0]*a[1];
        else
        {
            if((a[0]*a[1])%2==0)
            len=a[0]*a[1];
            else
            len=a[0]*a[1]-1+sqrt(2);
            
        }
        
    
        cas++;
        printf("Scenario #%d:\n",cas);
        if(n>=0)
        {
        printf("%.2f\n",len);
        cout<<endl;
        }
        //else
        //printf("%.2f\n",len);
     
        
        
    }
    return 0;
}
bubuko.com,布布扣

 

1046,布布扣,bubuko.com

1046

标签:des   style   blog   class   code   java   

原文地址:http://www.cnblogs.com/hezixiansheng8/p/3715229.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!