码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2852 KiKi's K-Number(线段树+树状数组)

时间:2014-08-14 16:47:38      阅读:237      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   java   os   io   strong   for   

KiKi‘s K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2603    Accepted Submission(s): 1202


Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?
 

Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.
 

Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
 

Sample Input
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
 

Sample Output
No Elment! 6 Not Find! 2 2 4 Not Find!
 


线段树差点超时,感觉还是树状数组棒,但是毕竟刚学线段树,要练手

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 300010;
const int maxm = 100001;
#define lson l, mid, rt<<1
#define rson mid+1, r, rt<<1|1
#define MAX INT_MAX
#define MIN INT_MIN
struct node
{
    int left,right;
    int num;
}T[maxm<<2];
int ans = 0;
void Creat(int left,int right,int id)//建树
{
    T[id].left =left;
    T[id].right =right;
    T[id].num =0;
    if(T[id].left ==T[id].right )
        return ;
    Creat(left,(left+right)/2,2*id);
    Creat((left+right)/2+1,right,2*id+1);
}
void UPdata(int id,int i,int j)
{
    if(T[id].left<=i&&T[id].right >=i)
        T[id].num +=j;
    if(T[id].left ==T[id].right )
        return;
    if(i>T[id].right )
        return;
    if(i<T[id].left )
        return;
    int mid=(T[id].left +T[id].right )/2;
    if(i<=mid)
        UPdata(id*2,i,j);
    else
        UPdata(id*2+1,i,j);
}
void query(int id,int l,int r)
{
    int mid=(T[id].left +T[id].right)/2;
    if(T[id].left ==l&&T[id].right ==r)
    {
        ans+=T[id].num ;
        return;
    }
    if(r<=mid)
        query(2*id,l,r);
    else if(l>mid)
        query(2*id+1,l,r);
    else
    {
        query(2*id,l,mid);
        query(2*id+1,mid+1,r);
    }

}

int B_search(int x)
{
    int low = 1;
    int high = maxm;
    int mid,wz=-1;
    while(low<=high)
    {
        mid = (low + high) / 2;
       ans = 0;
        query(1,1,mid);
        if(ans>=x)
        {
            high = mid - 1;
            wz = mid;
        }
        else
        {
            low = mid+1;
        }
    }
    return wz;
}
int main()
{
    int n,a,b,k;
    while(~scanf("%d",&n))
    {
        Creat(1,100001,1);
        for(int i = 0;i<n;i++)
        {
            scanf("%d",&a);
        if(a==0)
        {
            scanf("%d",&b);
            UPdata(1,b,1);
        }
        else if(a==1)
        {
            scanf("%d",&b);
         ans = 0;
         query(1,b,b);
            if(!ans)
                puts("No Elment!");
            else
                UPdata(1,b,-1);
        }
        else if(a==2)
        {
            scanf("%d%d",&b,&k);

           ans = 0;
          query(1,1,b);
           int tem = B_search(ans+k);
           if(tem!=-1)
                printf("%d\n",tem);
            else
                puts("Not Find!");
        }
        }
    }
    return 0;
}

树状数组

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#define init(a) memset(a,0,sizeof(a))
using namespace std;
#define MAX INT_MAX
#define MIN INT_MIN
#define LL __int64
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1
const int maxn = 300010;
const int maxm = 100010;
using namespace std;
int c[maxn];
int hash[maxm];
int lowbit(int x)
{ 
    return x&(-x);
}
void add(int x,int w)
{
    while(x<=maxn)
    {
        c[x]+=w;
        x+=lowbit(x);
    }
}
int sum(int i)
{
    int s=0;
    while(i>0)
    {
        s += c[i];
        i =i - lowbit(i);
    }
    return s;
}
void B_search(int b,int k)
{
     int tem = sum(b);
    int low = b;
    int high = maxm;
    int mid;
    while(low <= high)
    {
        mid = (low + high) /2;
        int st = sum(mid);
        if(hash[mid]>0 && st-hash[mid]-tem<k&&st-tem>=k)
        {
            break;
        }
        if(st-tem<k)
        {
            low = mid + 1;
        }
        else
            high = mid - 1;
    }
    printf("%d\n",mid);
}
bool query(int b,int k)
{
    if(sum(maxn)-sum(b)<k)return 0;
    B_search(b,k);
    return 1;
}

int main()
{
    int n,a,b,k;
    while(scanf("%d",&n)!=EOF)
    {
        init(c);
        init(hash);

        for(int i=0;i<n;i++)
        {
            scanf("%d",&a);
            if(a==0)
            {
                scanf("%d",&b);
                add(b,1);
                hash[b]++;
            }
            else if(a==1)
            {
                scanf("%d",&b);
                if(hash[b]>0)
                {
                     add(b,-1);
                     hash[b]--;
                }
                else
                    puts("No Elment!");
            }
            else if(a==2)
            {
                scanf("%d%d",&b,&k);
               bool tep =  query(b,k);
               if(!tep)
                puts("Not Find!");
            }
        }
    }
    return 0;
}


HDU 2852 KiKi's K-Number(线段树+树状数组),布布扣,bubuko.com

HDU 2852 KiKi's K-Number(线段树+树状数组)

标签:des   style   color   java   os   io   strong   for   

原文地址:http://blog.csdn.net/wjw0130/article/details/38559433

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!