码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1182 食物链 (带关系的并查集)

时间:2014-08-14 19:34:09      阅读:281      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   for   

 

食物链

Time Limit: 1000MS
Memory Limit: 10000K

Total Submissions: 44835
Accepted: 13069

Description

动物王国中有三类动物A,B,C,这三类动物的食物链构成了有趣的环形。A吃B, B吃C,C吃A。
现有N个动物,以1-N编号。每个动物都是A,B,C中的一种,但是我们并不知道它到底是哪一种。
有人用两种说法对这N个动物所构成的食物链关系进行描述:
第一种说法是"1 X Y",表示X和Y是同类。
第二种说法是"2 X Y",表示X吃Y。
此人对N个动物,用上述两种说法,一句接一句地说出K句话,这K句话有的是真的,有的是假的。当一句话满足下列三条之一时,这句话就是假话,否则就是真话。
1) 当前的话与前面的某些真的话冲突,就是假话;
2) 当前的话中X或Y比N大,就是假话;
3) 当前的话表示X吃X,就是假话。
你的任务是根据给定的N(1 <= N <= 50,000)和K句话(0 <= K <= 100,000),输出假话的总数。

Input

第一行是两个整数N和K,以一个空格分隔。
以下K行每行是三个正整数 D,X,Y,两数之间用一个空格隔开,其中D表示说法的种类。
若D=1,则表示X和Y是同类。
若D=2,则表示X吃Y。

Output

只有一个整数,表示假话的数目。

Sample Input

100 7
1 101 1 
2 1 2
2 2 3 
2 3 3 
1 1 3 
2 3 1 
1 5 5

Sample Output

3

Source

Noi 01

 

总结:用集合维护同时成立的关系

/*
 * 对每只动物建立3个元素A,B,C,位置分别为i, i+n, i+2*n
 * i-X 表示i属于种类X
 * 并查集中每一组表示组内所有元素代表的情况都同时发生或不发生
 */
#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=50000*3+5;
const int maxk=100000+5;
int p[maxn];

void make_set()
{
    memset(p, -1, sizeof(p));
}

int find_set(int x)
{
    return p[x]==-1 ? x : p[x]=find_set(p[x]);
}

void union_set(int x, int y)
{
    int fx=find_set(x), fy=find_set(y);
    if(fx==fy) return;
    p[fx]=fy;
}

bool same(int x, int y)
{
    return find_set(x)==find_set(y);
}


int main()
{
    int n, k;
    scanf("%d%d", &n, &k);
    int d, x, y;
    int ans=0;
    make_set();
    for(int i=0;i<k;i++)
    {
        scanf("%d%d%d", &d, &x, &y);
        if(x>n || y>n || (d==2 && x==y)) { ans++; continue; }
        x--; y--;

        if(d==1)//x y 属于同一类
        {
            if(same(x, y+n) || same(x, y+2*n))
                ans++;
            else
            {
                union_set(x, y);
                union_set(x+n, y+n);
                union_set(x+2*n, y+2*n);
            }
        }
        else if(d==2) {//x 吃 y
            if(same(x, y) || same(x, y+2*n))
                ans++;
            else
            {
                union_set(x, y+n);
                union_set(x+n, y+2*n);
                union_set(x+2*n, y);
            }
        }
    }
    printf("%d\n", ans);

    return 0;
}

 

网上发现另一种解法,但是不是很理解,后面研究一下:

http://endless.logdown.com/posts/2014/04/10/find-sets-notes-differential-statistics-maintenance

http://blog.csdn.net/synapse7/article/details/18517109

http://blog.csdn.net/ditian1027/article/details/20804911

poj 1182 食物链 (带关系的并查集),布布扣,bubuko.com

poj 1182 食物链 (带关系的并查集)

标签:des   style   blog   http   color   os   io   for   

原文地址:http://www.cnblogs.com/cute/p/3912925.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!