码迷,mamicode.com
首页 > 其他好文 > 详细

C - Surprising Strings

时间:2014-08-14 20:18:19      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   io   strong   for   

                               C - Surprising Strings

题意:输入一段字符串,假设在同一距离下有两个字符串同样输出Not surprising
,否则输出surprising。


Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.


Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.



#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <map>
using namespace std;
char s[500];
char t[500];
int main()
{
    int i,j;
    int n;
    while(scanf("%s",s)!=EOF)
    {
        if(s[0]=='*')
            break;
         n = strlen(s);
         bool flag = true;
         for(i=0;i<n;i++)
         {
             if(!flag)
                break;
             map<string,int>mapp;
             for(j=0;j+i+1<n;j++)
             {
                 if(!flag)
                    break;
                t[0] = s[j];
                t[1] = s[j+i+1];
                t[2] = '\0';
                if(mapp[t]>0)
                {
                    printf("%s is NOT surprising.\n",s);
                    flag = false;
                }
                else
                    mapp[t]++;
             }
         }
            if(flag)
			cout<<s<<" is surprising."<<endl;
    }
    return 0;
}


C - Surprising Strings,布布扣,bubuko.com

C - Surprising Strings

标签:des   style   blog   color   os   io   strong   for   

原文地址:http://www.cnblogs.com/zfyouxi/p/3913194.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!