码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-4950 Monster

时间:2014-08-14 20:31:09      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

http://acm.hdu.edu.cn/showproblem.php?pid=4950

Monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 151    Accepted Submission(s): 64


Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round‘s attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".
 

 

Input
There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).
 

 

Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".
 

 

Sample Input
5 3 2 2
0 0 0 0
 

 

Sample Output
Case #1: NO
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
      int t=1;
     __int64 h,a,b,k;
    while(~scanf("%I64d%I64d%I64d%I64d",&h,&a,&b,&k))
    {
        if(h==0&&a==0&&b==0&&k==0)
              break;
         printf("Case #%d: ",t++);

         if(h<=a)
           {

              printf("YES\n");
               continue;
           }
           if(a<=b)
              {
                  printf("NO\n");
                  continue;
              }
        if(h-((a-b)*(k-1)+a)<=0)
           {

              printf("YES\n");
               continue;
           }

         if(h-(a-b)*k+b>=h)
            {
                printf("NO\n");
                continue;
            }
        else
          {

              printf("YES\n");
              continue;
          }
    }
    return 0;
}

 

HDU-4950 Monster,布布扣,bubuko.com

HDU-4950 Monster

标签:des   style   blog   http   color   java   os   io   

原文地址:http://www.cnblogs.com/cancangood/p/3913253.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!