码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3461 Oulipo(KMP模板题)

时间:2014-08-14 20:38:29      阅读:273      评论:0      收藏:0      [点我收藏+]

标签:poj   kmp   

题目链接:http://poj.org/problem?id=3461

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23559   Accepted: 9437

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source


题意:

寻找子串在母串出现的次数!

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
#define MAXN 1000017
int next[MAXN];
char s1[MAXN],s2[MAXN];
int k;
void getnext( char T[],int len)
{
    int i = 0, j = -1;
    next[0] = -1;
    while(i < len)
    {
        if(j == -1 || T[i] == T[j])
        {
            i++,j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}
void  KMP(int len1, int len2 )
{
	int i = 0, j = 0 ;
	k=0;
	next[0] = -1 ;
	while( i < len1 && j < len2 )
	{
		if( j == -1 || s1[i] == s2[j])
		{
			i++;j++;
		}
		else
			j = next[j];
		if( j == len2)
		{
			k++;
			j = next[j];
		}
	}
}
int main()
{
	int t;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		gets(s2);//待匹配子串
		int len2 = strlen(s2);
		getnext(s2,len2);
		gets(s1);//总串(母串)
		int len1 = strlen(s1);
		KMP(len1, len2);
		printf("%d\n",k);
	}
    return 0;
}


bubuko.com,布布扣

poj 3461 Oulipo(KMP模板题),布布扣,bubuko.com

poj 3461 Oulipo(KMP模板题)

标签:poj   kmp   

原文地址:http://blog.csdn.net/u012860063/article/details/38562751

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!