码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3617 Best Cow Line

时间:2016-11-07 00:47:44      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:bsp   cst   cow   return   algorithm   sub   ems   pen   sha   

Best Cow Line
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 20226   Accepted: 5563

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows‘ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he‘s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial (‘A‘..‘Z‘) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A‘..‘Z‘) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD

题目大意:给这些奶牛重新排序,每次从队首或队尾拿出一个字母,使得排序后的字典序最小。

贪心的去做。

/* ***********************************************
Author        :guanjun
Created Time  :2016/10/30 20:47:50
File Name     :poj3617.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;


char s[2200];
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int n;
    cin>>n;
    for(int i=0;i<n;i++)cin>>s[i];
    int l=0;
    int r=n-1;
    string t="";
    while(l<=r){
        int flag=0;
        for(int i=0;l+i<=r;i++){
            if(s[l+i]<s[r-i]){
                flag=1;
                break;
            }
            else if(s[l+i]>s[r-i]){
                flag=0;
                break;
            }
        }
        if(flag){
            t+=s[l++];
        }
        else t+=s[r--];
    }
    for(int i=0;i<n;i++){
        cout<<t[i];
        if((i+1)%80==0)cout<<endl;
    }
    cout<<endl;
    return 0;
}
//aba

 

poj 3617 Best Cow Line

标签:bsp   cst   cow   return   algorithm   sub   ems   pen   sha   

原文地址:http://www.cnblogs.com/pk28/p/6036781.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!