码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-4952 Number Transformation

时间:2014-08-14 23:08:56      阅读:178      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

http://acm.hdu.edu.cn/showproblem.php?pid=4952

Number Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 171    Accepted Submission(s): 69


Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.
 

 

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).
 

 

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.
 

 

Sample Input
2520 10
2520 20
0 0
 

 

Sample Output
Case #1: 2520
Case #2: 2600
 

 

Source
#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    __int64 x,i,k,j;
    int t=1;
    while(~scanf("%I64d%I64d",&x,&k))
    {
         if(x==0&&k==0)
            break;
         i=2;
         while(i<=k)
         {
             if(x%i!=0)
             {
                j=x/i+1;//求倍数。
                  if(j<=i)
                    {
                        x=k*j;
                        break;
                    }
                x=j*i;
             }
             else
              {
                 j=x/i;
                 if(j<=i)
                    {
                        x=k*j;
                        break;
                    }
              }
             i++;
         }
      printf("Case #%d: %I64d\n",t++,x);
    }
    return 0;
}

 

 

HDU-4952 Number Transformation,布布扣,bubuko.com

HDU-4952 Number Transformation

标签:des   style   blog   http   color   java   os   io   

原文地址:http://www.cnblogs.com/cancangood/p/3913275.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!