码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1253--胜利大逃亡--简单BFS

时间:2016-11-08 22:39:12      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:namespace   iss   ios   ace   show   题目   pop   推出   for   

转自http://www.cnblogs.com/yuyixingkong/p/3245297.html

代码是我的..

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 21759    Accepted Submission(s): 8538

Problem Description

 

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.
魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
技术分享

 

 

 

Input

 

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)
特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

 

Output
 
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1. 

 

Sample Input

 

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0
 
Sample Output
 
11

 

/*-----------------------------------------------------------------------

本题是搜索题,从囚徒出发,搜索到出口的最短路线的距离值(或者反向,由出口开始,搜索到囚徒的位置的距离值),容易想到的是宽度优先搜索,首先将囚徒的点放入先进先出的一个队列,并记录走过的时间(或距离),以后不断地

(1)将队列中先进的元素推出,还原为实际储存点后,

(2)六向搜索通路点,并将搜索到的通路点放进先进先出队列。

(3)重复(1),(2),直到搜索到目标点(出口)或队列为空为止,前者只要搜索得的值低于题目给出的T值,就输出此值,其余情况输出-1;

-------------------------------------------------------------------------

本题目有几个大坑:

1,门有可能是墙壁;(墙壁不可出,但是一开始人站的地方是墙居然又可以)

2,题目给出的某些CASE的T值小于囚徒到门口的空间最短距离(A+B+C-3)。不要忘记-1的情况

3,开始可以是墙,不影响,

掉进去会使用时增多,如果你的搜索效率再不高的,就很可能超时了。

----------------------------------------------------------------------------------*/

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1253

这道题没什么特别难的地方,只是有几个bug要注意一下

技术分享
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<iomanip>
#include<queue>
#define INF 0x7ffffff
#define MAXN 51
using namespace std;
const double eps=1e-10;
int m[MAXN][MAXN][MAXN];
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
struct node
{
    int a;
    int b;
    int c;
    int n;
};
int vis[MAXN][MAXN][MAXN];
int x,y,z;
int a,b,c;
int n;
int nn;
bool ok()
{
    if(x>=0&&x<a&&y>=0&&y<b&&z>=0&&z<c)
        return 1;
    else return 0;
}
int BFS()
{
    queue<struct node> route;
    struct node tem;
    struct node buf;
    buf.a=0;
    buf.b=0;
    buf.c=0;
    buf.n=0;
    vis[0][0][0]=1;
    route.push(buf);
    while(!route.empty()) {
        //cout<<11111<<endl;
        buf=route.front();
        route.pop();
        if(buf.a==a-1&&buf.b==b-1&&buf.c==c-1) {
            return buf.n;
        }
        if(buf.n>n){
            return -1;
        }
        //nn=buf.n+1;
        for(int i=0; i<6; i++){
            x=buf.a+dir[i][0];
            y=buf.b+dir[i][1];
            z=buf.c+dir[i][2];
            if(ok()&&m[x][y][z]==0&&vis[x][y][z]==0) {
                if(abs(x-a+1)+abs(y-a+1)+abs(z-c+1)+buf.n>n)//很棒的剪枝思路,见大坑2
                    continue;
                vis[x][y][z]=1;
                tem.a=x;
                tem.b=y;
                tem.c=z;
                tem.n=buf.n+1;
                route.push(tem);
            }
        }
    }
    return -1;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("data2.in", "r", stdin);
    #endif
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);
    int t;
    int res=0;
    cin>>t;
    while(t--){
        a=b=c=x=y=z=0;
        nn=0;
        memset(vis,0,sizeof(vis));
        cin>>a>>b>>c>>n;
        for(int i=0;i<a;i++){
            for(int j=0;j<b;j++){
                for(int k=0;k<c;k++){
                    cin>>m[i][j][k];
                }
            }
        }
        cout<<BFS()<<endl;
    }
}

/* 5 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0 3 3 4 20 1 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 1 3 3 4 10 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0 3 3 4 21 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 1 0 0 1 1 0 0 1 1 0 */ /* 11 11 -1 -1 -1 */
技术分享

HDU1253--胜利大逃亡--简单BFS

标签:namespace   iss   ios   ace   show   题目   pop   推出   for   

原文地址:http://www.cnblogs.com/liuzhanshan/p/6044913.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!