码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3746 Cyclic Nacklace(KMP求循环节)

时间:2016-11-09 05:57:44      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:http   course   思路   com   imu   desc   mos   log   sim   

Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl‘s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls‘ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet‘s cycle is 9 and its cyclic count is 2:
技术分享

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a‘ ~‘z‘ characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3
aaa
abca
abcde

Sample Output

0
2
5

题意:给一个字符串,问至少需要增加几个字符使修改后的字符串含有至少两个循环节。
此题给出两个基于KMP的思路。
思路一:发现KMP的前缀next数组len-nxt[len]就是该字符串的最小循环节。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 4;
char s[maxn];
int nxt[maxn];
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%s",&s);
                //next数组的构建
		int j = 0, k = -1;
		int len = strlen(s);
		nxt[0] = -1;
		while(j<len){
			if(k == -1 || s[j] == s[k]){
				j++;
				k++;
				nxt[j] = k;
			}
			else k = nxt[k];
		}
                //只有一个循环节
		if(nxt[len] == 0){
			printf("%d\n",len);
			continue;
		}
		int pos = len - nxt[len];
		int res;
                //有完整的多个循环节
		if(len % pos == 0) res = 0;
                //不完整的循环节
		else res = pos - len % pos;
		printf("%d\n",res);
	}
}

思路二:用一个该串作为模板串,从原串的第二个字符去匹配。相差的即为最小循环节。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 1e5 + 4;
char s[maxn];
int nxt[maxn];
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%s",&s);
                //构建next数组
		int j = 0, k = -1;
		int len = strlen(s);
		nxt[0] = -1;
		while(j<len){
			if(k == -1 || s[j] == s[k]){
				j++;
				k++;
				nxt[j] = k;
			}
			else k = nxt[k];
		}
		//应用kmp
		int i = 1; k = 0;
		while(i<len){
			while(k != -1 && s[i] != s[k]) k = nxt[k];
			++i;
			++k;
		}
		int pos = len - k;
		int res = (pos - (len % pos)) % pos;
		if(pos == len) res = len;
		printf("%d\n",res);
	}
}

 

 


 


HDU 3746 Cyclic Nacklace(KMP求循环节)

标签:http   course   思路   com   imu   desc   mos   log   sim   

原文地址:http://www.cnblogs.com/bywmm/p/6045214.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!