码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1200 Crazy Search(Hash)

时间:2014-08-14 23:55:56      阅读:329      评论:0      收藏:0      [点我收藏+]

标签:des   style   os   io   for   ar   div   amp   

Description

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5.

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac

Sample Output

5

Hint

Huge input,scanf is recommended.

hash的运用。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
using namespace std;
const int maxn=16000000+100;
char s[maxn];
int a[10000];
int hash[maxn];
int main()
{
    int n,nc;
    while(~scanf("%d%d",&n,&nc))
    {
        getchar();
        int num=0,sum;
        scanf("%s",s);
        int len=strlen(s);
        for(int i=0;i<len;i++)
        {
            if(!a[s[i]])
                a[s[i]]=++num;//巧妙的运用下标
        }
        int cnt=0;
        for(int i=0;i+n-1<len;i++)
        {
            sum=0;
            for(int j=i;j<i+n;j++)
                sum=sum*nc+a[s[j]];//可以考虑转换成nc进制下的数
            if(!hash[sum])//判重
            {
                hash[sum]=1;
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


POJ 1200 Crazy Search(Hash),布布扣,bubuko.com

POJ 1200 Crazy Search(Hash)

标签:des   style   os   io   for   ar   div   amp   

原文地址:http://blog.csdn.net/u013582254/article/details/38568179

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!