码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1908 Double Queue<Set>

时间:2014-08-14 23:56:36      阅读:520      评论:0      收藏:0      [点我收藏+]

标签:des   style   使用   os   io   for   ar   div   

Problem Description
The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

 

Input
Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

 

Output
For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

 

Sample Input
2 1 20 14 1 30 3 2 1 10 99 3 2 2 0
 

Sample Output
0 20 30 10 0 STL乃神器,set的使用。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<set>
using namespace std;
struct node{
    int v,p;
    bool operator<(const node &a)const//p大的优先
    {   return p>a.p;    }
};

int main()
{
    int u;
    set<node>q;
    node temp;
    while(~scanf("%d",&u))
    {
        if(u==0)
            break;
        if(u==1)
        {
            scanf("%d%d",&temp.v,&temp.p);
            q.insert(temp);
        }
        else if(q.empty())
            puts("0");
        else if(u==2)
        {
            printf("%d\n",q.begin()->v);
            q.erase(q.begin());
        }
        else
        {
            set<node>::iterator it=q.end();
            it--;
            printf("%d\n",it->v);
            q.erase(it);
        }
    }
    return 0;
}


HDU 1908 Double Queue<Set>,布布扣,bubuko.com

HDU 1908 Double Queue<Set>

标签:des   style   使用   os   io   for   ar   div   

原文地址:http://blog.csdn.net/u013582254/article/details/38567977

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!