码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1328 Radar Installation

时间:2014-08-15 01:28:36      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:des   blog   os   io   for   ar   art   问题   


Description
Assume the coasting is an infinite straight line.
Land is in one side of coasting, sea in the other.
Each small island is a point locating in the sea side.
And any radar installation, locating on the coasting, can only cover d distance,
so an island in the sea can be covered by a radius installation,
if the distance between them is at most d.

We use Cartesian coordinate system,
defining the coasting is the x-axis.
The sea side is above x-axis, and the land side below.
Given the position of each island in the sea,
and given the distance of the coverage of the radar installation,
your task is to write a program to find the minimal number of radar installations
to cover all the islands.
Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations


Input
The input consists of several test cases.
The first line of each case contains two integers n (1<=n<=1000) and d,
where n is the number of islands in the sea
and d is the distance of coverage of the radar installation.
This is followed by n lines each containing two integers
representing the coordinate of the position of each island.

Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output
For each test case output one line consisting of the test case number followed
by the minimal number of radar installations needed.

"-1" installation means no solution for that case.

Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1

 

首先计算出每个海岛对应的能够在海岸线上修建雷达站的区间

再按区间的左值排序 题目就转化为了区间选点的贪心问题

 

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#define mem(a,b) memset(a,b,sizeof(a))
#define ll __int64
#define MAXN 1000
#define INF 0x7ffffff
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
struct Island
{
    double l,r;
};
Island p[12000];
int cmp(Island a,Island b)
{
    return a.l<b.l;
}
int main()
{
    int n,m,i,j,cnt=1;
    int sum,ok;
    int x,y,r;
    while(scanf("%d%d",&n,&r)!=EOF)
    {
        if(n==0&&r==0) break;
        ok= 1;sum=1;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            if(y>r)ok=0;
            if(ok)
            {
              p[i].l=x-sqrt((double)(r*r-y*y));
              p[i].r=x+sqrt((double)(r*r-y*y));
            }
        }
        if(!ok)
        {
            printf("Case %d: -1\n",cnt++);
            continue;
        }
        sort(p,p+n,cmp);
        double mark=p[0].r;
        for(i=1;i<n;i++)
        {
            if(mark<p[i].l)
            {
                sum++;
                mark=p[i].r;
            }
            if(mark>p[i].r)
                mark=p[i].r;
        }
        printf("Case %d: %d\n",cnt++,sum);
    }
    return 0;
}

  

 

这是一开始的代码 感觉思路也没有错 估计是精度误差太大

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#define mem(a,b) memset(a,b,sizeof(a))
#define ll __int64
#define MAXN 1000
#define INF 0x7ffffff
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
struct Island
{
    double x,y;
};
Island p[1200];
int sum;

int cmp(Island a,Island b)
{
    if(a.x!=b.x) return a.x<b.x;
    return a.y>b.y;
}
int main()
{
    int n,m,i,j,cnt=1;
    int sum;
    double x,y,r;
    while(scanf("%d%lf",&n,&r)!=EOF)
    {
        if(n==0&&r==0) break;
        int ok= 1;
            sum=1;
        for(i=0;i<n;i++)
        {
            scanf("%lf%lf",&p[i].x,&p[i].y);
            if(p[i].y>r)  ok=0;
        }
        if(!ok)
        {
            printf("-1\n");
            continue;
        }
        sort(p,p+n,cmp);

        for(i=0;i<n;i++)
        {
            if(i==0)   x=sqrt(r*r-p[i].y*p[i].y)+p[i].x;
            else
            {
                if(p[i].y*p[i].y+(p[i].x-x)*(p[i].x-x)>r*r)
                {
                    sum++;
                    x=sqrt(r*r-p[i].y*p[i].y)+p[i].x;
                }
            }
        }
        printf("Case %d: %d\n",cnt++,sum);
    }
    return 0;
}

  

poj 1328 Radar Installation,布布扣,bubuko.com

poj 1328 Radar Installation

标签:des   blog   os   io   for   ar   art   问题   

原文地址:http://www.cnblogs.com/sola1994/p/3913756.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!