码迷,mamicode.com
首页 > 其他好文 > 详细

hdoj:2071

时间:2016-11-12 22:19:17      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:blog   int   border   sub   count   top   center   ack   ase   

Max Num

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22270    Accepted Submission(s): 13029



Problem Description
There are some students in a class, Can you help teacher find the highest student .
 

Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 

Output
For each case output the highest height, the height to two decimal plases;
 

Sample Input
2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00
 

Sample Output
180.00 182.00

 

#include <iostream>

using namespace std;

int main()
{
    int t,count;
    double score,max = -1;
    cin >> t;
    for (int i = 1; i <= t; i++)
    {
        cin >> count;
        max = -1;
        while (count--)
        {    
            cin >> score;
            max = max > score ? max : score;
        }
        printf("%.2lf\n", max);
    }
}

hdoj:2071

标签:blog   int   border   sub   count   top   center   ack   ase   

原文地址:http://www.cnblogs.com/theskulls/p/6057397.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!