码迷,mamicode.com
首页 > 其他好文 > 详细

二叉树计数(codevs 3112)

时间:2016-11-12 23:25:37      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:class   cout   递推   ios   long   span   define   tput   std   

题目描述 Description

一个有n个结点的二叉树总共有多少种形态

输入描述 Input Description

读入一个正整数n

输出描述 Output Description

输出一个正整数表示答案

样例输入 Sample Input

6

样例输出 Sample Output

132

数据范围及提示 Data Size & Hint

1<=n<=20

/*
  复习一下卡特兰数,以备考试考上模板(虽然可能性不大)
  递推式:h[1]=1,h[i]=(4*i-2)*h[i-1]/(n+1) 
  数列模式:1 1 2 5 14 42 132 429 …… 
*/
#include<cstdio>
#include<iostream> 
#define lon long long
using namespace std;
lon h[25];int n;
int main(){
    scanf("%d",&n);
    h[1]=1;
    for(int i=2;i<=n;i++){
        h[i]=(lon)(4*i-2)*h[i-1]/(lon)(i+1);
    }
    cout<<h[n];
    return 0;
}

 

二叉树计数(codevs 3112)

标签:class   cout   递推   ios   long   span   define   tput   std   

原文地址:http://www.cnblogs.com/harden/p/6057601.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!