码迷,mamicode.com
首页 > 其他好文 > 详细

HDU_1532_最大流

时间:2016-11-13 11:34:53      阅读:216      评论:0      收藏:0      [点我收藏+]

标签:max   one   nat   layout   ble   eof   other   string   cap   

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15853    Accepted Submission(s): 7544


Problem Description
Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 
 

 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond. 
 

 

Sample Input
5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10
 

 

Sample Output
50
 
 
最大流裸题。Edmonds-Karp算法。
 
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
#define N 200
#define LL long long
#define INF 2000000005

queue<int>q;
int flow[N][N];
int cap[N][N];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(cap,0,sizeof(cap));
        for(int i=0; i<n; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(cap[a][b]==0)
            {
                cap[a][b]=c;
            }
            else
            {
                cap[a][b]+=c;
            }
        }
        while(!q.empty())
            q.pop();
        int totf=0;
        int p[N];
        memset(flow,0,sizeof(flow));
        for(;;)
        {
            int a[N];
            memset(a,0,sizeof(a));
            a[1]=INF;
            q.push(1);
            while(!q.empty())
            {
                int u=q.front();
                q.pop();
                for(int v=1; v<=m; v++)
                    if(!a[v]&&cap[u][v]>flow[u][v])
                    {
                        p[v]=u;
                        q.push(v);
                        if(cap[u][v]-flow[u][v]>a[u])
                            a[v]=a[u];
                        else
                            a[v]=cap[u][v]-flow[u][v];
                    }
            }
            if(a[m]==0)
                break;
            for(int u=m; u!=1; u=p[u])
            {
                flow[p[u]][u]+=a[m];
                flow[u][p[u]]-=a[m];
            }
            totf+=a[m];
            //cout<<"here"<<endl;
        }
        printf("%d\n",totf);
    }
    return 0;
}

 

HDU_1532_最大流

标签:max   one   nat   layout   ble   eof   other   string   cap   

原文地址:http://www.cnblogs.com/jasonlixuetao/p/6058270.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!