码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2505 A multiplication game[博弈论]

时间:2016-11-13 21:51:00      阅读:138      评论:0      收藏:0      [点我收藏+]

标签:mis   main   cat   bsp   enter   for   oca   idt   log   

A multiplication game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6028   Accepted: 3013

Description

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.

Input

Each line of input contains one integer number n.

Output

For each line of input output one line either 
Stan wins. 
or 
Ollie wins. 
assuming that both of them play perfectly.

Sample Input

162
17
34012226

Sample Output

Stan wins.
Ollie wins.
Stan wins.

Source


手算一下吧
0~9 stan
10~9*2 ollie  //2是Stan,他要尽量阻止Ollie取到n;9是Ollie,他要尽量大来取到n
19~9*2*9 stan
以此类推
可以直接用n不断/18
注意double n
#include<cstdio>
double n;
int main(){
    while(scanf("%lf",&n)!=EOF){
        while(n>18) n/=18;
        if(n<=9) puts("Stan wins.");
        else puts("Ollie wins.");
    }
}

 

POJ2505 A multiplication game[博弈论]

标签:mis   main   cat   bsp   enter   for   oca   idt   log   

原文地址:http://www.cnblogs.com/candy99/p/6059819.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!