码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1651 区间dp

时间:2016-11-13 22:10:30      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:cat   i+1   poi   size   ace   i++   ast   元素   first   

题目链接:http://poj.org/problem?id=1651

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650
思路:dp[1][n] 表示答案。
求解dp[i][j]的时候,就是枚举[i+1,j-1]中最后删除的元素。dp[i][j]=min(dp[i][j],a[k]*a[i]*a[j]+dp[i][k]+dp[k][j])   i<k<j
具体看代码吧应该是比较好理解的。
//我觉得我自己写的代码也没什么问题啊,但是就是不过。不懂为什么。sad。加油练习!别气馁,坚持下去。
代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define ll long long
const int maxn=1e2+5;
const int INF=0x3f3f3f3f;

int dp[105][105];
int a[105];

int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++) scanf("%d",&a[i]);
        for(int d=2; d<n; d++)
        for(int i=1; i+d<=n; i++){
            int j=i+d;
            dp[i][j]=INF;
            for(int k=i+1; k<j; k++)
            dp[i][j]=min(dp[i][j],dp[i][k]+dp[k][j]+a[k]*a[i]*a[j]);
        }
        printf("%d\n",dp[1][n]);
    }
    return 0;
}

 

poj 1651 区间dp

标签:cat   i+1   poi   size   ace   i++   ast   元素   first   

原文地址:http://www.cnblogs.com/a-clown/p/6059913.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!