码迷,mamicode.com
首页 > 其他好文 > 详细

hd1425 sort【堆排序】

时间:2014-08-15 09:31:37      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   java   os   io   strong   

sort

Time Limit: 6000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27771    Accepted Submission(s): 8400

Problem Description
给你n个整数,请按从大到小的顺序输出其中前m大的数。
Input
每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。
Output
对每组测试数据按从大到小的顺序输出前m大的数。
Sample Input
5 3 3 -35 92 213 -644
Sample Output
213 92 3
知识点:堆、STL
#include <stdio.h>
#include <algorithm>
using namespace std;
int a[1000000];
int main()
{
    int i,n,m;
    while(EOF != scanf("%d %d",&n,&m))
    {
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        make_heap(a,a+n);
        printf("%d",a[0]);
        for(i=1;i<m;i++)
        {
            pop_heap(a,a+n-i+1);
            printf(" %d",a[0]);
        }
        printf("\n");
    }
    return 0;
}


hd1425 sort【堆排序】,布布扣,bubuko.com

hd1425 sort【堆排序】

标签:des   style   blog   color   java   os   io   strong   

原文地址:http://blog.csdn.net/hpuhjl/article/details/38580095

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!