码迷,mamicode.com
首页 > 其他好文 > 详细

An easy problem

时间:2016-11-15 10:13:28      阅读:128      评论:0      收藏:0      [点我收藏+]

标签:who   close   blog   lines   title   div   scanf   lap   blocks   

An easy problem
Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc.. 
技术分享

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem : 

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ? 

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. 
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ? 

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10 10).

Output

For each case, output the number of ways in one line.

Sample Input

2
1
3

Sample Output

0
1

技术分享
#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        long long n;
        scanf("%I64d",&n);
        n++;
        int ans=0;
        long long m=sqrt(n);
        for(long long i=2;i<=m;i++)
        {
            if(n%i==0) ans++;
        }
        printf("%d\n",ans);
    }
}
View Code

n=i*j+i+j

==>n+1=(i+1)*(j+1)

 

 

An easy problem

标签:who   close   blog   lines   title   div   scanf   lap   blocks   

原文地址:http://www.cnblogs.com/superxuezhazha/p/6064322.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!