码迷,mamicode.com
首页 > 其他好文 > 详细

Big Event in HDU

时间:2016-11-15 10:59:12      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:ace   his   ini   tar   different   lin   trouble   max   which   

Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002. 
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds). 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different. 
A test case starting with a negative integer terminates input and this test case is not to be processed. 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B. 

Sample Input

2
10 1
20 1
3
10 1 
20 2
30 1
-1

Sample Output

20 10
40 40

好久不刷题了,看到这个题一点思路也没有。后来想了一下,其实不难。把一组数,分解为和尽量相等的2组数。
看作01背包问题,背包容量为sum/2,求怎么组合可以最大可能的接近sum/2.
#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
using namespace std;
    int val[50*100+5];
    int dp[250005];
int max(int a,int b)
{
    if(a>=b) return a;
    else return b;
}
int main()
{

    int n;
    while(~scanf("%d",&n)&&n>0)
    {
        memset(dp,0,sizeof(dp));
        int sum=0;
        int num=0;
        for(int i=0;i<n;i++)
        {
            int tmp1,tmp2;
            scanf("%d%d",&tmp1,&tmp2);
            while(tmp2>0)
            {
                val[num++]=tmp1;
                sum+=tmp1;
                tmp2--;
            }
        }
        for(int i=0;i<num;i++)
        {
            for(int j=sum/2;j>=val[i];j--)
            {
                dp[j]=max(dp[j-val[i]]+val[i],dp[j]);
            }
        }
        printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
    }
    return 0;
}

 

Big Event in HDU

标签:ace   his   ini   tar   different   lin   trouble   max   which   

原文地址:http://www.cnblogs.com/superxuezhazha/p/6064294.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!