码迷,mamicode.com
首页 > 其他好文 > 详细

Balanced Lineup

时间:2016-11-15 14:09:30      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:min   splay   最小值   sed   include   enter   2.0   cli   cat   

 
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 49061   Accepted: 22975
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1..Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0


题目大意:给出一个数字序列,对于每次提问,输出区间(i,j)内的最大值数与最小值数的差。RMQ模板题。


技术分享
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N  50010
#define ll long long
using namespace std;
int f[N][20],fi[N][20],a[N];
int n,m;
void RMQ()
{
    for (int i=1;i<=n;i++) f[i][0]=a[i],fi[i][0]=a[i];
    for (int i=1;i<=floor(log(n)/log(2));i++)
      for (int j=1;j<=n+1-(1<<i);j++)
        {
            f[j][i]=max(f[j][i-1],f[j+(1<<i-1)][i-1]);//区间最大值 
            fi[j][i]=min(fi[j][i-1],fi[j+(1<<i-1)][i-1]);//区间最小值 
        }
        
}
int main()
{
    while (scanf("%d%d",&n,&m)!=EOF)
      {
           for (int i=1;i<=n;i++) scanf("%d",&a[i]);
         RMQ();
         for (int i=1,x,y;i<=m;i++)
            {
                 scanf("%d%d",&x,&y);
                 int k; 
                 k=(int) (log(y-x+1.0)/log(2.0)); //如果k=(log(y-x+1)/log(2)),那么当log(8)/log(2)时,k=2 
                 int ans1=max(f[x][k],f[y-(1<<k)+1][k]),ans2=min(fi[x][k],fi[y-(1<<k)+1][k]);
                 printf("%d\n",ans1-ans2);
            }
      }
   
    return 0;
}
rmq

 

 

Balanced Lineup

标签:min   splay   最小值   sed   include   enter   2.0   cli   cat   

原文地址:http://www.cnblogs.com/sjymj/p/6065223.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!