码迷,mamicode.com
首页 > 其他好文 > 详细

uva 657 - The die is cast

时间:2014-08-15 12:16:38      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   

  The die is cast 

InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixels connected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

 

bubuko.com,布布扣

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence bubuko.com,布布扣 in S such that a = a1 and b = ak , and ai and ai+1 are connected for bubuko.com,布布扣.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected‘ means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

 

Input 

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy bubuko.com,布布扣.

The following h lines contain w characters each. The characters can be: ``.‘‘ for a background pixel, ``*‘‘ for a pixel of a die, and ``X‘‘ for a pixel of a die‘s dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

 

Output 

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

 

Sample Input 

 

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

 

Sample Output 

Throw 1
1 2 2 4
#include <iostream>
#include <stack>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <queue>
#include <set>
#include <map>
#include <fstream>
#include <stack>
#include <list>
#include <sstream>
#include <cmath>

using namespace std;

#define ms(arr, val) memset(arr, val, sizeof(arr))
#define mc(dest, src) memcpy(dest, src, sizeof(src))
#define N 55
#define INF 0x3fffffff
#define vint vector<int>
#define setint set<int>
#define mint map<int, int>
#define lint list<int>
#define sch stack<char>
#define qch queue<char>
#define sint stack<int>
#define qint queue<int>

int ans[2500], p;

char image[N][N];
int dir[4][2] = {0, -1, -1, 0, 1, 0, 0, 1};
//必须要两个dfs
void _dfs(int i, int j)
{
    if (image[i][j] == X)
    {
        image[i][j] = .;
        for (int k = 0; k < 4; k++)
        {
            _dfs(i + dir[k][0], j + dir[k][1]);
        }
    }
}

void dfs(int i, int j)
{
    if (image[i][j] != .)
    {
        if (image[i][j] == X)
        {
            _dfs(i, j);//寻找相邻的X
            ans[p]++;
        }
        else
            image[i][j] = .;
        for (int k = 0; k < 4; k++)
        {
            dfs(i + dir[k][0], j + dir[k][1]);
        }
    }
}
int main()
{
    int w, h, cases = 1;
    ms(image[0], .);
    while (scanf("%d%d", &w, &h), w && h)
    {
        for (int i = 1; i <= h; i++)
        {
            scanf("%s", image[i] + 1);
            image[i][0] = image[i][w + 1] = .;
        }
        ms(image[h + 1], .);//不能少
        ms(ans, 0);
        p = 0;
        for (int i = 1; i <= h; i++)
        {
            for (int j = 1; j <= w; j++)
            {
                if (image[i][j] != .)
                {
                    dfs(i, j);
                    p++;
                }
            }
        }
        sort(ans, ans + p);
        printf("Throw %d\n", cases++);
        printf("%d", ans[0]);
        for (int i = 1; i < p; i++)
        {
            printf(" %d", ans[i]);
        }
        printf("\n\n");
    }
    return 0;
}

 

uva 657 - The die is cast,布布扣,bubuko.com

uva 657 - The die is cast

标签:des   style   blog   http   color   os   io   strong   

原文地址:http://www.cnblogs.com/jecyhw/p/3914377.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!