码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2777 Count Color(线段树)

时间:2014-08-15 12:52:18      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   使用   os   io   strong   

Count Color
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 35248   Accepted: 10622

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

题解及代码:


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <set>
#include <map>
#include <queue>
#include <string>
#define maxn 100100
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define ALL %I64d
using namespace std;
typedef __int64  ll;
ll P_2[34];   //我们使用2^p代表第p中颜色
void init()
{
    P_2[0]=1;
    for(int i=1; i<=33; i++)
    {
        P_2[i]=2*P_2[i-1];
    }
}

struct segment
{
    int l,r;
    ll value;
    ll nv;
} son[maxn<<2];

void PushUp(int rt)
{                      //使用或操作,代表两端区间中颜色数合并
    son[rt].value=son[rt<<1].value|son[rt<<1|1].value;
}

void Build(int l,int r,int rt)
{
    son[rt].l=l;
    son[rt].r=r;
    son[rt].nv=0;
    if(l==r)
    {
        son[rt].value=P_2[1];
        return;
    }
    int m=(l+r)/2;
    Build(lson);
    Build(rson);
    PushUp(rt);
}


void Update_n(ll w,int l,int r,int rt)
{
    if(son[rt].l==l&&son[rt].r==r)
    {
        son[rt].value=w;
        son[rt].nv=w;
        return;
    }

    if(son[rt].nv)
    {
        son[rt<<1].nv=son[rt].nv;
        son[rt<<1|1].nv=son[rt].nv;
        son[rt<<1].value=son[rt].nv;
        son[rt<<1|1].value=son[rt].nv;
        son[rt].nv=0;
    }

    int m=(son[rt].l+son[rt].r)/2;

    if(r<=m)
        Update_n(w,l,r,rt<<1);
    else if(l>m)
        Update_n(w,l,r,rt<<1|1);
    else
    {
        Update_n(w,lson);
        Update_n(w,rson);
    }
    PushUp(rt);
}


ll  Query(int l,int r,int rt)
{
    if(son[rt].l==l&&son[rt].r==r)
    {
        return son[rt].value;
    }

    if(son[rt].nv)
    {
        son[rt<<1].nv=son[rt].nv;
        son[rt<<1|1].nv=son[rt].nv;
        son[rt<<1].value=son[rt].nv;
        son[rt<<1|1].value=son[rt].nv;
        son[rt].nv=0;
    }

    ll ret=0;
    int m=(son[rt].l+son[rt].r)/2;

    if(r<=m)
        ret=Query(l,r,rt<<1);
    else if(l>m)
        ret=Query(l,r,rt<<1|1);
    else
    {
        ret=Query(lson);
        ret=ret|Query(rson);
    }
    //PushUp(rt);
    return ret;
}
int main()
{
    init();
    int n,m,t,l,r;
    ll w;
    char s[4];
    while(scanf("%d%d%d",&n,&t,&m)!=EOF)
    {
        Build(1,n,1);
        for(int i=1; i<=m; i++)
        {
            scanf("%s",s);
            if(s[0]=='C')
            {
                scanf("%d%d%I64d",&l,&r,&w);
                if(l>r) swap(l,r);
                Update_n(P_2[w],l,r,1);
            }
            else
            {
                scanf("%d%d",&l,&r);
                if(l>r) swap(l,r);
                ll ans=0,v=Query(l,r,1);
                while(v)    //得到代表颜色的2进制数,把不同的颜色数目求出来
                {
                    if(v%2)
                        ans++;
                    v>>=1;
                }
                printf("%I64d\n",ans);
            }
        }
    }
    return 0;
}
/*
挺好玩的一道题目,题目的意思给定一块木板,分成l段,我们进行两种操作,
一种是指定l-r段涂成同一种颜色,一种是查询l-r区间中不同的颜色数。

因为颜色数比较少,这里我们可以使用位操作来记录短浅区间中一共有多少种颜色,
也就是位运算”或“,具体见代码吧。
*/




poj 2777 Count Color(线段树),布布扣,bubuko.com

poj 2777 Count Color(线段树)

标签:des   style   blog   color   使用   os   io   strong   

原文地址:http://blog.csdn.net/knight_kaka/article/details/38582855

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!