码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2222 Keywords Search(AC自动机模板题)

时间:2014-08-15 14:36:48      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   java   os   io   

Keywords Search

                                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a‘-‘z‘, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
1 5 she he say shr her yasherhs
 

Sample Output
3
 
题意:给出n个单词和一个文本串,问在文本串中有多少个单词出现过。
分析:AC自动机入门题,不需要任何转化。
学习AC自动机较好的参考资料:http://www.cs.uku.fi/~kilpelai/BSA05/lectures/slides04.pdf
#include<cstdio>

const int N = 10010;
char str[1000005];
struct node
{
    node *next[26];
    node *fail;
    int count;
    node() {
        for(int i = 0; i < 26; i++)
            next[i] = NULL;
        count = 0;
        fail = NULL;
    }
}*q[50*N];
node *root;
int head, tail;

void Insert(char *str)
{
    node *p = root;
    int i = 0, index;
    while(str[i]) {
        index = str[i] - 'a';
        if(p->next[index] == NULL)
            p->next[index] = new node();
        p = p->next[index];
        i++;
    }
    p->count++;
}
void build_ac_automation(node *root)
{
    root->fail = NULL;
    q[tail++] = root;
    while(head < tail) {
        node *temp = q[head++];
        node *p = NULL;
        for(int i = 0; i < 26; i++) {
            if(temp->next[i] != NULL) {
                if(temp == root) temp->next[i]->fail = root;
                else {
                    p = temp->fail;
                    while(p != NULL) {
                        if(p->next[i] != NULL) {
                            temp->next[i]->fail = p->next[i];
                            break;
                        }
                        p = p->fail;
                    }
                    if(p == NULL) temp->next[i]->fail = root;
                }
                q[tail++] = temp->next[i];
            }
        }
    }
}
int Query(node *root)
{
    int i = 0, cnt = 0, index;
    node *p = root;
    while(str[i]) {
        index = str[i] - 'a';
        while(p->next[index] == NULL && p != root) p = p->fail;
        p = p->next[index];
        if(p == NULL) p = root;
        node *temp = p;
        while(temp != root && temp->count != -1) {
            cnt += temp->count;
            temp->count = -1;
            temp = temp->fail;
        }
        i++;
    }
    return cnt;
}

int main()
{
    int T, n;
    scanf("%d",&T);
    while(T--) {
        head = tail = 0;
        root = new node();
        scanf("%d",&n);
        while(n--) {
            scanf("%s", str);
            Insert(str);
        }
        build_ac_automation(root);
        scanf("%s",str);
        printf("%d\n", Query(root));
    }
    return 0;
}

hdu 2222 Keywords Search(AC自动机模板题),布布扣,bubuko.com

hdu 2222 Keywords Search(AC自动机模板题)

标签:des   style   blog   http   color   java   os   io   

原文地址:http://blog.csdn.net/lyhvoyage/article/details/38584681

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!