码迷,mamicode.com
首页 > 其他好文 > 详细

hdu1498--50 years, 50 colors(二分匹配,题意。。。)

时间:2014-08-15 14:43:38      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   java   os   io   strong   

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1617    Accepted Submission(s): 881


Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it‘s so nice, isn‘t it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What‘s more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

bubuko.com,布布扣

 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
-1 1 2 1 2 3 4 5 -1
 

题意,给出n*n的矩阵,每个点上一个气球,颜色有的不同,对每一种颜色可以打k次,每次可以打掉一行或者一列的相同颜色的色球。如果可以消灭完,就不输出,否则输出气球的颜色,如果全部消灭完 输出-1

就是对每一种颜色进行一次二分匹配,判断可不可以在k次内消灭完。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int mm[120][120] , c[100] ;
struct node
{
    int v ;
    node *next ;
} *head[120];
int link[120] , temp[120] , top , p[120];
int f(int i)
{
    for( node *q = head[i] ; q != NULL ; q = q->next )
    {
        int v = q->v ;
        if( !temp[v] )
        {
            temp[v] = 1 ;
            if( link[v] == -1 || f( link[v] ) )
            {
                link[v] = i ;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i , j , k , n , m , ans  ;
    while(scanf("%d %d", &n, &m) && n+m != 0)
    {
        memset(c,0,sizeof(c));
        for(i = 1 ; i <= n ; i++)
            for(j = 1 ; j <= n ; j++)
            {
                scanf("%d", &mm[i][j]);
                c[ mm[i][j] ]++ ;
            }
        top = 0 ;
        for(i = 1 ; i <= 50 ; i++)
        {
            ans = 0 ;
            memset(head,NULL,sizeof(head));
            memset(link,-1,sizeof(link));
            if( !c[i] )
                continue ;
            for(j = 1 ; j <= n ; j++)
                for(k = 1 ; k <= n ; k++)
                {
                    if( mm[j][k] == i )
                    {
                        node *q = new node ;
                        q->v = k ;
                        q->next = head[j] ;
                        head[j] = q ;
                    }
                }
            for(j = 1 ; j <= n ; j++)
            {
                memset(temp,0,sizeof(temp));
                if(  f(j) )
                    ans++ ;
            }
            if( ans > m )
                p[top++] = i ;
        }
        if(top == 0)
            printf("-1\n");
        else
        {
            for(i = 0 ; i < top ; i++)
                if(i == top-1)
                    printf("%d\n", p[i]);
                else

                    printf("%d ", p[i]);
        }
    }
    return 0;
}


 

hdu1498--50 years, 50 colors(二分匹配,题意。。。),布布扣,bubuko.com

hdu1498--50 years, 50 colors(二分匹配,题意。。。)

标签:des   style   http   color   java   os   io   strong   

原文地址:http://blog.csdn.net/winddreams/article/details/38583691

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!