码迷,mamicode.com
首页 > 其他好文 > 详细

Prerequisites?[HDU1144]

时间:2016-11-21 22:55:27      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:i++   repr   rom   sam   log   problem   mit   lag   ros   

Prerequisites?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1220 Accepted Submission(s): 698


Problem Description
Freddie the frosh has chosen to take k courses. To meet the degree requirements, he must take courses from each of several categories. Can you assure Freddie that he will graduate, based on his course selection?

 

Input
Input consists of several test cases. For each case, the first line of input contains 1 ≤ k ≤ 100, the number of courses Freddie has chosen, and 0 ≤ m ≤ 100, the number of categories. One or more lines follow containing k 4-digit integers follow; each is the number of a course selected by Freddie. Each category is represented by a line containing 1 ≤ c ≤ 100, the number of courses in the category, 0 ≤ r ≤ c, the minimum number of courses from the category that must be taken, and the c course numbers in the category. Each course number is a 4-digit integer. The same course may fulfil several category requirements. Freddie‘s selections, and the course numbers in any particular category, are distinct. A line containing 0 follows the last test case.

 

Output
For each test case, output a line containing "yes" if Freddie‘s course selection meets the degree requirements; otherwise output "no."

 

Sample Input
3 2
0123 9876 2222
2 1 8888 2222
3 2 9876 2222 7654
3 2
0123 9876 2222
2 2 8888 2222
3 2 7654 9876 2222
0

Sample Output
yes
no

技术分享
#include<stdio.h>
int main()
{
    int k,m,c,r,d,i,j,l,flag,res,a[102];
    while(scanf("%d%d",&k,&m),k)
    {
        flag=1;
        for(i=0;i<k;i++)
            scanf("%d",&a[i]);
        for(i=0;i<m;i++)
        {
            scanf("%d%d",&c,&r);
            res=0;
            for(j=0;j<c;j++)
            {
                scanf("%d",&d);
                for(l=0;l<k;l++)
                    if(d==a[l])
                        res++;
            }
            if(res>=r)
                continue;
            else
                flag=0;
        }
        if(flag)
            printf("yes\n");
        else    
            printf("no\n");
    }
    return 0;
}
View Code

 

Prerequisites?[HDU1144]

标签:i++   repr   rom   sam   log   problem   mit   lag   ros   

原文地址:http://www.cnblogs.com/dramstadt/p/6087063.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!