码迷,mamicode.com
首页 > 其他好文 > 详细

简单题

时间:2014-08-15 17:58:49      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:简单题

原题http://acm.hdu.edu.cn/showproblem.php?pid=4950

Monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 566    Accepted Submission(s): 231


Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.

Monster initially has h HP. And it will die if HP is less than 1.

Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.

After k consecutive round‘s attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.

Output "YES" if Teacher Mai can kill this monster, else output "NO".


 

Input
There are multiple test cases, terminated by a line "0 0 0 0".

For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).


 

Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".


 

Sample Input
5 3 2 2 0 0 0 0


 

Sample Output
Case #1: NO
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;

int main()
{
    __int64 cas=1;
    __int64 h,a,b,k;

   while(~scanf("%I64d%I64d%I64d%I64d",&h,&a,&b,&k)){
        if(h==0 && a==0 && b==0 && k==0){
            break;
        }

        if(h <= a){
            printf("Case #%I64d: YES\n",cas++);
            continue;
        }
        if(a <= b){
            printf("Case #%I64d: NO\n",cas++);
            continue;
        }
        if(h-(a-b)*(k-1)-a <= 0){//K回合之内就打败了,不能回血。
            printf("Case #%I64d: YES\n",cas++);
            continue;
        }
        if(h-(a-b)*(k)+b < h){
            printf("Case #%I64d: YES\n",cas++);
            continue;
        }
        else{
            printf("Case #%I64d: NO\n",cas++);
        }
   }

   return 0;
}


 

简单题,布布扣,bubuko.com

简单题

标签:简单题

原文地址:http://blog.csdn.net/zcr_7/article/details/38587041

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!