码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 1536(尼姆博弈)

时间:2014-08-15 18:01:39      阅读:333      评论:0      收藏:0      [点我收藏+]

标签:尼姆博弈   杭电   算法   

S-Nim

<span size="+0"><strong><span style="font-family:Arial;font-size:12px;color:green;FONT-WEIGHT: bold">Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4479    Accepted Submission(s): 1941
</span></strong></span>

Problem Description
Arthur and his sister Caroll have been playing a game called Nim for some time now. Nim is played as follows:


  The starting position has a number of heaps, all containing some, not necessarily equal, number of beads.

  The players take turns chosing a heap and removing a positive number of beads from it.

  The first player not able to make a move, loses.


Arthur and Caroll really enjoyed playing this simple game until they recently learned an easy way to always be able to find the best move:


  Xor the number of beads in the heaps in the current position (i.e. if we have 2, 4 and 7 the xor-sum will be 1 as 2 xor 4 xor 7 = 1).

  If the xor-sum is 0, too bad, you will lose.

  Otherwise, move such that the xor-sum becomes 0. This is always possible.


It is quite easy to convince oneself that this works. Consider these facts:

  The player that takes the last bead wins.

  After the winning player‘s last move the xor-sum will be 0.

  The xor-sum will change after every move.


Which means that if you make sure that the xor-sum always is 0 when you have made your move, your opponent will never be able to win, and, thus, you will win. 

Understandibly it is no fun to play a game when both players know how to play perfectly (ignorance is bliss). Fourtunately, Arthur and Caroll soon came up with a similar game, S-Nim, that seemed to solve this problem. Each player is now only allowed to remove a number of beads in some predefined set S, e.g. if we have S =(2, 5) each player is only allowed to remove 2 or 5 beads. Now it is not always possible to make the xor-sum 0 and, thus, the strategy above is useless. Or is it? 

your job is to write a program that determines if a position of S-Nim is a losing or a winning position. A position is a winning position if there is at least one move to a losing position. A position is a losing position if there are no moves to a losing position. This means, as expected, that a position with no legal moves is a losing position.
 

Input
Input consists of a number of test cases. For each test case: The first line contains a number k (0 < k ≤ 100 describing the size of S, followed by k numbers si (0 < si ≤ 10000) describing S. The second line contains a number m (0 < m ≤ 100) describing the number of positions to evaluate. The next m lines each contain a number l (0 < l ≤ 100) describing the number of heaps and l numbers hi (0 ≤ hi ≤ 10000) describing the number of beads in the heaps. The last test case is followed by a 0 on a line of its own.
 

Output
For each position: If the described position is a winning position print a ‘W‘.If the described position is a losing position print an ‘L‘. Print a newline after each test case.
 

Sample Input
2 2 5 3 2 5 12 3 2 4 7 4 2 3 7 12 5 1 2 3 4 5 3 2 5 12 3 2 4 7 4 2 3 7 12 0
 

Sample Output
LWW WWL
 

Source
Norgesmesterskapet 2004 
 
思路:尼姆博弈的变形,套用了sg函数
代码如下:
 
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int k,a[110],f[10010];
int mex(int p)//sg函数
{
	int i,t;
	bool g[110]={0};
	for(i=0;i<k;i++)
	{
		t=p-a[i];
		if(t<0)
		break;
		if(f[t]==-1)
		f[t]=mex(t);
		g[f[t]]=1;
	}
	for(i=0;;i++)
	if(!g[i])
	return i;
}
int main()
{
	int n,i,m,j,t,s;
	while(~scanf("%d",&k),k)
	{
		for(i=0;i<k;i++)
		scanf("%d",&a[i]);
		sort(a,a+k);
		memset(f,-1,sizeof(f));
		f[0]=0;
		scanf("%d",&n);
		while(n--)
		{
			scanf("%d",&m);
			s=0;
			while(m--)
			{
				scanf("%d",&t);
				if(f[t]==-1)
				f[t]=mex(t);
				s^=f[t];//尼姆博弈,各个堆的数量的异或和为零的话,先手输
			}
			if(s==0)
			printf("L");
			else
			printf("W");//题上的没有换行,注意细节 ,此处没有换行符
		}
		printf("\n");
	}
	return 0;
}

杭电 1536(尼姆博弈),布布扣,bubuko.com

杭电 1536(尼姆博弈)

标签:尼姆博弈   杭电   算法   

原文地址:http://blog.csdn.net/ice_alone/article/details/38586707

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!