码迷,mamicode.com
首页 > 其他好文 > 详细

find your present (感叹一下位运算的神奇)

时间:2016-11-22 23:08:18      阅读:195      评论:0      收藏:0      [点我收藏+]

标签:lin   rom   eve   can   because   tom   diff   amp   cee   

find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21948    Accepted Submission(s): 8671


Problem Description
In the new year party, everybody will get a "special present".Now it‘s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present‘s card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

 

Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

 

Output
For each case, output an integer in a line, which is the card number of your present.
 

 

Sample Input
5 1 1 3 2 2 3 1 2 1 0
 

 

Sample Output
3 2
Hint
Hint
use scanf to avoid Time Limit Exceeded
 
 
//找出不同的那个数
#include <bits/stdc++.h>
using namespace std;
int main()
{
	int i;
	int n;
	int temp;
	int a;
	while(scanf("%d",&n)!=EOF && n!=0)
	{
		temp=0;
		while(n--)
		{
			scanf("%d",&a);
			temp = a ^ temp;
	    }
	    cout<<temp<<endl;
	}
	return 0;
}

  

find your present (感叹一下位运算的神奇)

标签:lin   rom   eve   can   because   tom   diff   amp   cee   

原文地址:http://www.cnblogs.com/upstart/p/6091359.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!