标签:des style http color java os io strong
Monster
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 590 Accepted Submission(s): 238
Problem Description
Teacher Mai has a kingdom. A monster has invaded this kingdom, and Teacher Mai wants to kill it.
Monster initially has h HP. And it will die if HP is less than 1.
Teacher Mai and monster take turns to do their action. In one round, Teacher Mai can attack the monster so that the HP of the monster will be reduced by a. At the end of this round, the HP of monster will be increased by b.
After k consecutive round‘s attack, Teacher Mai must take a rest in this round. However, he can also choose to take a rest in any round.
Output "YES" if Teacher Mai can kill this monster, else output "NO".
Input
There are multiple test cases, terminated by a line "0 0 0 0".
For each test case, the first line contains four integers h,a,b,k(1<=h,a,b,k <=10^9).
Output
For each case, output "Case #k: " first, where k is the case number counting from 1. Then output "YES" if Teacher Mai can kill this monster, else output "NO".
Sample Input
Sample Output
Source
题解及代码:
签到题,不多讲,分成三个阶段模拟,第一阶段,看是否能一下就把怪物杀死;第二阶段,进行到第k回合,假设我进行攻击,怪物未回血,看是否能将其杀死;
第三阶段,进行玩第k+1回合,看这几个回合下来怪物是否掉血了。
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int cas=1;
long long h,m,n,t;
while(scanf("%I64d%I64d%I64d%I64d",&h,&m,&n,&t)!=EOF)
{
if(!h&&!m&&!n&&!t)
break;
if(m<=n)
{
if(h<=m)
{
printf("Case #%d: YES\n",cas++);
}
else
{
printf("Case #%d: NO\n",cas++);
}
continue;
}
if(m*t-n*(t-1)>=h)
{
printf("Case #%d: YES\n",cas++);
}
else
{
if(m*t-n*(t+1)>=1)
printf("Case #%d: YES\n",cas++);
else
printf("Case #%d: NO\n",cas++);
}
}
return 0;
}
hdu 4950 Monster,布布扣,bubuko.com
hdu 4950 Monster
标签:des style http color java os io strong
原文地址:http://blog.csdn.net/knight_kaka/article/details/38588859