标签:des style blog http color os io strong
http://poj.org/problem?id=2151
Check the difficulty of problems
Time Limit: 2000MS |
|
Memory Limit: 65536K |
Total Submissions: 4873 |
|
Accepted: 2131 |
Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:
1. All of the teams solve at least one problem.
2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.
Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.
Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?
Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0
Sample Output
0.972
分析:求保证每个队至少做对一题,冠军队做对n个题的概率。
保证每个队至少做对一题,冠军队做对n个题的概率=每个队至少做对一道题-没有一个队做到n到题。(每个队最多做了n-1个题),
dp[i][j][k]表示第i个对做到j题,目前做对了k题。
dp[i][j[k]=dp[i][j-1][k]*(1-a[i][j])+dp[i][j-1][k-1]*a[i][j];
s[i][k]表示i对至少做对了k题的概率
注意边界。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
double dp[1005][40][40];
int main()
{
int m,t,n,i,j,k;
double a[1005][40],cnt,ans,sum,s[1005][40];
while(~scanf("%d%d%d",&m,&t,&n))
{
memset(dp,0,sizeof(dp));
memset(s,0,sizeof(s));
cnt=1;
ans=1;
sum=1;
if(m==0&&t==0&&n==0)
break;
for(i=1;i<=t;i++)
{
for(j=1;j<=m;j++)
{
scanf("%lf",&a[i][j]) ;
cnt*=(1-a[i][j]);
}
ans*=(1-cnt);
cnt=1;
}
for(i=1;i<=t;i++)
{
dp[i][1][0]=1-a[i][1];
dp[i][1][1]=a[i][1];
for(j=2;j<=m;j++)
dp[i][j][0]=dp[i][j-1][0]*(1-a[i][j]);
for(j=2;j<=m;j++)
{
for(k=1;k<=j;k++)
{
dp[i][j][k]=dp[i][j-1][k]*(1-a[i][j])+dp[i][j-1][k-1]*a[i][j];
}
}
for(k=1;k<=n-1;k++)
s[i][n-1]+=dp[i][m][k];
}
for(i=1;i<=t;i++)
{
sum*=s[i][n-1];
}
printf("%.3lf\n",ans-sum);
}
return 0;
}
poj 2151,布布扣,bubuko.com
poj 2151
标签:des style blog http color os io strong
原文地址:http://www.cnblogs.com/cancangood/p/3915756.html