码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 2706 Thermal Death of the Universe

时间:2014-08-16 11:07:10      阅读:209      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   io   strong   for   

 

Thermal Death of the Universe

Time Limit: 10 Seconds                                     Memory Limit: 32768 KB                            

Johnie has recently learned about the thermal death concept.  Given that the Global Entropy always increases, it will end in the  thermal death of the Universe. The idea has impressed him extremely.  Johnie does not want the universe to die this way. 

So he decided to emulate the process to check how soon the thermal death can occur. He has created the mathematical model of the process in the following way. The universe is represented as an array of n integer numbers. The life of the universe is represented as the sequence of the following entropy operations: take elements from ith to jth and replace them with their average value. Since their average is not necessarily integer, it is rounded. 

To keep balance, rounding is performed either up, or down depending on the current sum of all elements of the array. If their sum is less or equal to the sum of the original array, the rounding is  performed up, in the other case --- down.

Given the initial array and the sequence of the entropy operations, find the contents of the resulting array.

Input

There are mutiple cases in the input file.

The first line of each case contains n and m --- the size of the array and the number of operations respectively (1 <= m, n <= 30,000 ). The second line contains n integer numbers --- the initial contents of the array, they do not exceed 109 by their absolute value. The following m lines contain two integer numbers each and describe entropy operations.

There is an empty line after each case.

Output

Output n integer numbers --- the contents of the array after all operations.

There should be am empty line after each case.

Sample Input

6 4
1 2 3 4 5 6
1 2
2 5
5 6
4 6

Sample Output

2 3 3 5 5 5

 

赤裸裸的一条线段树,然后需要延时更新~~注意细节就是求值的时候要强转换成(LL)(r-l +1)*v

 

#include <bits/stdc++.h>

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define lr rt<<1
#define rr rt<<1|1

using namespace std;

typedef long long LL;
const int N = 30005;

LL osum;
int n,q;

struct ST
{
    int l,r;
    LL lazy,date;
    int mid(){
        return (l+r)>>1;
    }
}st[N<<2];

void push_down(int rt)
{
    if( st[rt].lazy )
    {
      st[lr].lazy =  st[rr].lazy = st[rt].lazy; 
      st[lr].date = (LL)( st[lr].r - st[lr].l +1 ) * st[lr].lazy; 
      st[rr].date = (LL)( st[rr].r - st[rr].l +1 ) * st[rr].lazy;
      st[rt].lazy=0;
    }
}

void build(int l,int r,int rt)
{
    st[rt].l=l,st[rt].r=r;
    st[rt].lazy=0;
    if(l==r)
    {
        scanf("%lld",&st[rt].date);
        osum += st[rt].date;
        return ;
    }

    int m=st[rt].mid();
    build(lson);
    build(rson);
    st[rt].date = st[rr].date + st[lr].date;
}

void update(int l,int r,int rt,LL v)
{
    if( l == st[rt].l && st[rt].r == r )
    {
        st[rt].date= (LL) ( r - l + 1 ) * v ;
        st[rt].lazy=v;
        return;
    }

    push_down(rt);

    int m=st[rt].mid();

    if( l > m )
        update(l,r,rr,v);
    else if(r <= m)
        update(l,r,lr,v);

    else{
            update(lson,v);
            update(rson,v);
        }
    st[rt].date = st[rr].date + st[lr].date;

}

LL query(int l,int r,int rt)
{


    if( l==st[rt].l && r==st[rt].r  )
    {
        return st[rt].date;
    }

    push_down(rt);
    
    int m=st[rt].mid();

    if(l > m)
        return query(l,r,rr);

    else if( r <= m)
        return query(l,r,lr);

    else
        return query(lson)+query(rson);
}

void show(int rt)
{
    if(st[rt].l == st[rt].r)
    {
        printf("%lld",st[rt].date);
        if(st[rt].r != n)printf(" ");
        else printf("\n");
        return;
    }
    int m=st[rt].mid();
    push_down(rt);
    show(lr);
    show(rr);
}

int main()
{
    int x,y;
   // freopen("in.txt","r",stdin);
    while(~scanf("%d%d",&n,&q)){
        osum=0;
        build(1,n,1);
        while(q--)
        {
            scanf("%d%d",&x,&y);
            if(x>y)swap(x,y);
            LL tmp = query(x,y,1);
            double ave = (long double)tmp/(y-x+1);
            if( st[1].date <= osum ) update(x, y,1,(LL)ceil(ave));
            else update( x, y, 1,(LL)floor(ave) );
          }
        show(1);
        puts("");
    }
    return 0;
}

 

ZOJ 2706 Thermal Death of the Universe,布布扣,bubuko.com

ZOJ 2706 Thermal Death of the Universe

标签:des   style   blog   color   os   io   strong   for   

原文地址:http://www.cnblogs.com/YRETSIM/p/3916092.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!