码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1201 Intervals 【差分约束系统】

时间:2014-08-16 11:11:46      阅读:323      评论:0      收藏:0      [点我收藏+]

标签:poj1201

Intervals
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 21591   Accepted: 8122

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
Write a program that: 
reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
writes the answer to the standard output. 

Input

The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6
因为这题不需要判断负环,所以不用添加虚拟节点,另外,求最短路径时,原点应该是最右边的点。

#include <stdio.h>
#include <string.h>
#include <queue>
#define maxn 50002
#define inf 0x3f3f3f3f
using std::queue;

int head[maxn], id, left, right, dist[maxn];
struct Node{
    int to, w, next;
} E[maxn << 2];
bool vis[maxn];

void addEdge(int a, int b, int c)
{
    E[id].to = b; E[id].w = c;
    E[id].next = head[a]; head[a] = id++;
}

int SPFA()
{
    int i, u, v, tmp;
    for(i = left; i <= right + 1; ++i){
        vis[i] = 0; dist[i] = inf;
    }
    queue<int> Q; Q.push(right);
    dist[right] = 0; vis[right] = 1;
    while(!Q.empty()){
        u = Q.front(); Q.pop();
        vis[u] = 0;
        for(i = head[u]; i != -1; i = E[i].next){
            v = E[i].to;
            tmp = dist[u] + E[i].w;
            if(tmp < dist[v]){
                dist[v] = tmp;
                if(!vis[v]){
                    vis[v] = 1;
                    Q.push(v);
                }
            }
        }
    }
    return -dist[left];
}

int main()
{
    //freopen("stdin.txt", "r", stdin);
    int n, a, b, c, i;
    while(scanf("%d", &n) == 1){
        memset(head, -1, sizeof(head));
        left = maxn; right = 0;
        for(i = id = 0; i < n; ++i){
            scanf("%d%d%d", &a, &b, &c);
            addEdge(b+1, a, -c);
            if(a < left) left = a;
            if(b > right) right = b;
        }
        ++right;
        for(i = left; i < right; ++i){
            addEdge(i+1, i, 0);
            addEdge(i, i+1, 1);
        }
        printf("%d\n", SPFA());
    }
    return 0;
}

正着求也对:

#include <stdio.h>
#include <string.h>
#include <queue>
#define maxn 50002
#define inf 0x3f3f3f3f
using std::queue;

int head[maxn], id, left, right, dist[maxn];
struct Node{
    int to, w, next;
} E[maxn << 2];
bool vis[maxn];

void addEdge(int a, int b, int c)
{
    E[id].to = b; E[id].w = c;
    E[id].next = head[a]; head[a] = id++;
}

int SPFA()
{
    int i, u, v, tmp;
    for(i = left; i <= right + 1; ++i){
        vis[i] = 0; dist[i] = -inf;
    }
    queue<int> Q; Q.push(left);
    dist[left] = 0; vis[left] = 1;
    while(!Q.empty()){
        u = Q.front(); Q.pop();
        vis[u] = 0;
        for(i = head[u]; i != -1; i = E[i].next){
            v = E[i].to;
            tmp = dist[u] + E[i].w;
            if(tmp > dist[v]){
                dist[v] = tmp;
                if(!vis[v]){
                    vis[v] = 1;
                    Q.push(v);
                }
            }
        }
    }
    return dist[right];
}

int main()
{
   // freopen("stdin.txt", "r", stdin);
    int n, a, b, c, i;
    while(scanf("%d", &n) == 1){
        memset(head, -1, sizeof(head));
        left = maxn; right = 0;
        for(i = id = 0; i < n; ++i){
            scanf("%d%d%d", &a, &b, &c);
            addEdge(a, b+1, c);
            if(a < left) left = a;
            if(b > right) right = b;
        }
        ++right;
        for(i = left; i < right; ++i){
            addEdge(i, i + 1, 0);
            addEdge(i+1, i, -1);
        }
        printf("%d\n", SPFA());
    }
    return 0;
}


POJ1201 Intervals 【差分约束系统】,布布扣,bubuko.com

POJ1201 Intervals 【差分约束系统】

标签:poj1201

原文地址:http://blog.csdn.net/chang_mu/article/details/38611263

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!