码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3666 Making the Grade DP

时间:2016-11-28 14:40:00      阅读:281      评论:0      收藏:0      [点我收藏+]

标签:ack   pre   namespace   success   第一个   des   排序   bin   alter   

Description

A straight dirt road connects two fields on FJ‘s farm, but it changes elevation more than FJ would like. His cows do not mind climbing up or down a single slope, but they are not fond of an alternating succession of hills and valleys. FJ would like to add and remove dirt from the road so that it becomes one monotonic slope (either sloping up or down).

You are given N integers A1, ... , AN (1 ≤ N ≤ 2,000) describing the elevation (0 ≤ Ai ≤ 1,000,000,000) at each of N equally-spaced positions along the road, starting at the first field and ending at the other. FJ would like to adjust these elevations to a new sequence B1, . ... , BN that is either nonincreasing or nondecreasing. Since it costs the same amount of money to add or remove dirt at any position along the road, the total cost of modifying the road is

|AB1| + |AB2| + ... + |AN - BN |

Please compute the minimum cost of grading his road so it becomes a continuous slope. FJ happily informs you that signed 32-bit integers can certainly be used to compute the answer.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single integer elevation: Ai

Output

* Line 1: A single integer that is the minimum cost for FJ to grade his dirt road so it becomes nonincreasing or nondecreasing in elevation.

Sample Input

7
1
3
2
4
5
3
9

Sample Output

3

Source

 

题意:将一个序列变为不递减或不递增序列的最小花费。

思路:由于题目要求并不是严格递增或递减,那么可以想到将一个数变化的最少花费肯定是变为数列中已有的第一个比它大或比它小的数。所以先排序,dp[i][j]代表选取到第i个,最后一位(最大)的是第a[j]的最小花费,转移方程为 dp[i][j] = min(dp[i-1][1~j]) + |a[i]-b[j]|。

 

 

/** @Date    : 2016-11-03-18.59
  * @Author  : Lweleth (SoungEarlf@gmail.com)
  * @Link    : https://github.com/
  * @Version :
  */
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
#include <utility>
#include <vector>
#include <map>
#include <set>
#include <math.h>
#include <string>
#include <stack>
#include <queue>
#define LL long long
#define MMF(x) memset((x),0,sizeof(x))
#define MMI(x) memset((x), INF, sizeof(x))
using namespace std;

const int INF = 0x3f3f3f3f;
const int N = 1e5+2000;

int dp[2010][2010];
int a[2010];
int b[2010];
int main()
{

    int n;
    while(cin >> n)
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%d", a + i);
            b[i] = a[i];
        }
        sort(b + 1, b + n + 1);
        a[0] = 0;
        int ans = INF, ans1 = INF;
        int mi, mii;

        for(int i = 0; i<= n; i++)
        {
            mi = INF;
            for(int j = 1; j <= n; j++)
            {
                if(i)
                {
                    dp[i][j] = INF;
                    dp[i][j] = min(dp[i-1][j], mi) + abs(a[i] - b[j]);
                    if(mi > dp[i-1][j])
                        mi = dp[i-1][j];
                    if(i == n)
                        ans = min(dp[n][j],ans);//注意这里取最小值
                }
                else dp[i][j] = 0;
            }
        }
        for(int i = 0; i<= n; i++)
        {
            mii = INF;
            for(int j = 1; j <= n; j++)
            {
                if(i)
                {
                    dp[i][j] = INF;
                    dp[i][j] = min(dp[i-1][j], mii) + abs(a[i] - b[n-j+1]);
                    if(mii > dp[i-1][j])
                        mii = dp[i-1][j];
                    if(i == n)
                        ans1 = min(dp[n][j],ans1);//注意这里取最小值
                }
                else dp[i][j] = 0;
            }
        }
        for(int i = 1; i <= n; i++)
            ans1 = min(dp[n][i],ans1);

        printf("%d\n", min(ans,ans1));
    }
    return 0;
}

POJ 3666 Making the Grade DP

标签:ack   pre   namespace   success   第一个   des   排序   bin   alter   

原文地址:http://www.cnblogs.com/Yumesenya/p/6109106.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!