码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2352 Stars

时间:2014-08-16 13:51:10      阅读:263      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   strong   for   

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 32548   Accepted: 14221

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 
bubuko.com,布布扣

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


题解及代码:

        水题,直接上代码。


树状数组:


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#define maxn 32010
using namespace std;
typedef long long ll;

int level[maxn];
int c[maxn];

int lowbit(int i)
{
    return i&(-i);
}

int sum(int i)
{
    int ans=0;
    while(i>0)
    {
        ans+=c[i];
        i-=lowbit(i);
    }
    return ans;
}

void update(int i)
{
    while(i<=32001)
    {
        c[i]++;
        i+=lowbit(i);
    }
}


int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int x,y;
        memset(c,0,sizeof(c));
        memset(level,0,sizeof(level));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            level[sum(x+1)]++;
            update(x+1);
        }
        for(int i=0;i<n;i++)
        {
            printf("%d\n",level[i]);
        }
    }
    return 0;
}


线段树:


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#define maxn 32010
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
typedef long long ll;

int level[maxn];

struct segment
{
   int l,r;
   int value;
}son[maxn<<2];

void PushUp(int rt)
{
    son[rt].value=son[rt<<1].value+son[rt<<1|1].value;
}

void Build(int l,int r,int rt)
{
    son[rt].l=l;
    son[rt].r=r;
    son[rt].value=0;
    if(l==r) return;
    int m=(l+r)/2;
    Build(lson);
    Build(rson);
}

void Update(int p,int rt)
{
    if(son[rt].l==son[rt].r)
    {
        son[rt].value++;
        return;
    }

    int m=(son[rt].l+son[rt].r)/2;
    if(p<=m)
        Update(p,rt<<1);
    else Update(p,rt<<1|1);

    PushUp(rt);
}

int Query(int l,int r,int rt)
{
    if(son[rt].l==l&&son[rt].r==r)
    {
        return son[rt].value;
    }

    int m=(son[rt].l+son[rt].r)/2;
    int ret=0;

    if(r<=m)
        ret=Query(l,r,rt<<1);
    else if(l>m)
        ret=Query(l,r,rt<<1|1);
    else{
        ret=Query(lson);
        ret+=Query(rson);
    }
    return ret;
}

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        Build(1,32001,1);
        int x,y;
        //memset(c,0,sizeof(c));
        memset(level,0,sizeof(level));
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&x,&y);
            //cout<<Query(1,x+1,1)<<endl;;
            level[Query(1,x+1,1)]++;
            Update(x+1,1);
        }
        for(int i=0;i<n;i++)
        {
            printf("%d\n",level[i]);
        }
    }
    return 0;
}




poj 2352 Stars,布布扣,bubuko.com

poj 2352 Stars

标签:des   style   http   color   os   io   strong   for   

原文地址:http://blog.csdn.net/knight_kaka/article/details/38612675

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!