码迷,mamicode.com
首页 > 其他好文 > 详细

Interviewe

时间:2016-11-30 23:01:19      阅读:340      评论:0      收藏:0      [点我收藏+]

标签:cas   ide   namespace   could   elf   his   abi   output   pos   

Interviewe

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 945 Accepted Submission(s): 234
 
Problem Description
YaoYao has a company and he wants to employ m people recently. Since his company is so famous, there are n people coming for the interview. However, YaoYao is
so busy that he has no time to interview them by himself. So he decides to select exact m interviewers for this task.
YaoYao decides to make the interview as follows. First he queues the interviewees according to their coming order. Then he cuts the queue into m segments. The length
of each segment is技术分享, which means he ignores the rest interviewees (poor guys because they comes late). Then, each segment is assigned to an interviewer and the interviewer chooses the best one from them as the employee.
YaoYao’s idea seems to be wonderful, but he meets another problem. He values the ability of the ith arrived interviewee as a number from 0 to 1000. Of course, the better one is, the higher ability value one has. He wants his employees good enough, so the sum of the ability values of his employees must exceed his target k (exceed means strictly large than). On the other hand, he wants to employ as less people as possible because of the high salary nowadays. Could you help him to find the smallest m?
 
Input
The input consists of multiple cases.
In the first line of each case, there are two numbers n and k, indicating the number of the original people and the sum of the ability values of employees YaoYao wants to hire (n≤200000, k≤1000000000). In the second line, there are n numbers v1, v2, …, vn (each number is between 0 and 1000), indicating the ability value of each arrived interviewee respectively.
The input ends up with two negative numbers, which should not be processed as a case.
 
Output

            For each test case, print only one number indicating the smallest m you can find. If you can’t find any, output -1 instead.
 
Sample Input
11 300
7 100 7 101 100 100 9 100 100 110 110
-1 -1
 
Sample Output
3
Hint
We need 3 interviewers to help YaoYao. The first one interviews people from 1 to 3, the second interviews people from 4 to 6, and the third interviews people from 7 to 9. And the people left will be ignored. And the total value you can get is 100+101+100=301>300.
 
 
Source
2010 ACM-ICPC Multi-University Training Contest(5)——Host by BJTU
 
Recommend
zhengfeng
/*
一道一道有毒的题,忘了一种竟然可以n个线段
*/
#include<bits/stdc++.h>
using namespace std;
int d[200100][20];
int n,k,cur,ob,maxn;
void init()
{
    for (int j = 1; (1 << j) < n; j++){
        int t = (1 << j) - 1;
        for (int i = 0; i+t < n; i++){
            d[i][j] = max(d[i][j-1], d[i+(1<<(j-1))][j-1]);
        }
    }
}
inline int RMQ(int a, int b)
{
    int l = int(log(double(b-a+1))/log(2.0));
    return max(d[a][l], d[b+1-(1<<l)][l]);
}
int main()
{
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    while(scanf("%d%d",&n,&k)&&n>=0&&k>=0)
    {
        ob=0;
        maxn=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&d[i][0]);
            ob+=d[i][0];
            maxn=max(maxn,d[i][0]);
        }
        if(ob<=k)
        {
            puts("-1");
            continue;
        }
        init();//RMQ预处理
        /*二分找最小值*/
        int ans=n;
        for(int m=max(1,k/maxn);m<n;m++)
        {
            cur=0;
            int t=n/m;//分组的长度
            //cout<<"t="<<t<<endl;
            for(int i=1;i<=m;i++)//枚举的组数
            {
                cur+=RMQ(t*(i-1),t*i-1);
                //cout<<t*(i-1)+1<<" "<<t*i<<endl;
                if(cur>k)
                    break;
            }
            if(cur>k)
            {
                ans=m;
                break;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

Interviewe

标签:cas   ide   namespace   could   elf   his   abi   output   pos   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/6119559.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!