码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5944 Fxx and string(水题)

时间:2016-12-01 21:55:55      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:enter   ssi   compute   text   ted   ram   close   condition   ica   

传送门

Fxx and string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 1007    Accepted Submission(s): 422

Description

Problem Description
Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string S contains n lowercase letters S1S2…Sn.Now Fxx wants to know how many three tuple (i,j,k) there are which can meet the following conditions:

1、i,j,k are adjacent into a geometric sequence.

2、Si=‘y‘,Sj=‘r‘,Sk=‘x‘.

3.Either j|i or j|k

Input

In the first line, there is an integer T(1≤T≤100) indicating the number of test cases.
T lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed 10000).

Output

For each case, output the answer.

Sample Input

2 
xyyrxx
yyrrxxxxx

Sample Output

0
2

思路

 题意:青年理论计算机科学家Fxx得到了一个只包含小写字母的字符串。字符串的长度为n,下标从1开始,第 位的字母为s?i??,现在Fxx想知道有多少三元组(i,j,k)满足下列条件

  • 1、i,j,k三个数成等比数列
  • 2、si??=‘y‘,sj=r‘,sk=‘x‘
  • 3.i  j 和k j 中必须有整数
 题解:直接暴力枚举,重点在于选择合适的枚举量,如果去暴力字符串的话,肯定T,但是枚举公比的话,效率大大的提高,因为其增长速度很快
 
#include<bits/stdc++.h>
using namespace std;
const int maxn = 10005;
char str[maxn];

int main()
{
	freopen("input.txt","r",stdin);
	int T;
	scanf("%d",&T);
	while (T--)
	{
		scanf("%s",str+1);
		int len = strlen(str+1);
		int res = 0;
		for (int i = 1;i <= len && i <= len/4;i++)
		{
			for (int j = 2;i*j*j <= len;j++)
			{
				if (str[i] == ‘y‘ && str[i*j] == ‘r‘ && str[i*j*j] == ‘x‘)	res++;
				if (str[i] == ‘x‘ && str[i*j] == ‘r‘ && str[i*j*j] == ‘y‘)	res++;
			}
		}
		printf("%d\n",res);
	}
	return 0;
}

  

 
 

HDU 5944 Fxx and string(水题)

标签:enter   ssi   compute   text   ted   ram   close   condition   ica   

原文地址:http://www.cnblogs.com/zzy19961112/p/6123517.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!