码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1686 Oulipo(KMP)

时间:2014-08-16 19:50:11      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   for   ar   art   

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A‘, ‘B‘, ‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
1 3 0
 
裸的KMP,直接上代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <queue>
using namespace std;
char s2[10010],s1[1000010];
int sum,next[10010];
void get_next(int len)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||s2[i]==s2[j])
        {
            ++i;
            ++j;
//            if(s2[i]!=s2[j])
                next[i]=j;
//                next[i]=next[j];
        }
        else
            j=next[j];
    }
}
void kmp(int len1,int len2)
{
    int i=0,j=0;
    get_next(len2);
    while(i<len1)
    {
        if(j==-1||s1[i]==s2[j])
        {
            ++i;
            ++j;
        }
        else
            j=next[j];
        if(j==len2)
        {
            sum++;
            j=next[j];
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        getchar();
        scanf("%s",s2);
        scanf("%s",s1);
//        cout<<s1<<" "<<s2<<endl;
        int len1=strlen(s1);
        int len2=strlen(s2);
        sum=0;
        kmp(len1,len2);
        printf("%d\n",sum);
    }
    return 0;
}


HDU 1686 Oulipo(KMP),布布扣,bubuko.com

HDU 1686 Oulipo(KMP)

标签:des   style   color   os   io   for   ar   art   

原文地址:http://blog.csdn.net/u013582254/article/details/38615659

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!