码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ 2833-Friendship(并查集+优化)

时间:2014-08-16 19:52:01      阅读:269      评论:0      收藏:0      [点我收藏+]

标签:style   color   os   io   strong   for   ar   art   

Friendship

Time Limit: 3 Seconds      Memory Limit: 32768 KB

A friend is like a flower,
a rose to be exact,
Or maybe like a brand new gate
that never comes unlatched.

A friend is like an owl,
both beautiful and wise.
Or perhaps a friend is like a ghost,
whose spirit never dies.

A friend is like a heart that goes
strong until the end.
Where would we be in this world
if we didn‘t have a friend?

                       - By Emma Guest

Now you‘ve grown up, it‘s time to make friends. The friends you make in university are the friends you make for life. You will be proud if you have many friends.

Input

There are multiple test cases for this problem.

Each test case starts with a line containing two integers N, M (1 <= N <= 100‘000, 1 <= M <= 200‘000), representing that there are totally N persons (indexed from 1 to N) and M operations, then M lines with the form "M a b" (without quotation) or "Q a" (without quotation) follow. The operation "M a b" means that person a and b make friends with each other, though they may be already friends, while "Q a" means a query operation.

Friendship is transitivity, which means if a and b, b and c are friends then a and c are also friends. In the initial, you have no friends except yourself, when you are freshman, you know nobody, right? So in such case you have only one friend.

Output

For each test case, output "Case #:" first where "#" is the number of the case which starts from 1, then for each query operation "Q a", output a single line with the number of person a‘s friends.

Separate two consecutive test cases with a blank line, but Do NOT output an extra blank line after the last one.

Sample Input

3 5
M 1 2
Q 1
Q 3
M 2 3
Q 2
5 10
M 3 2
Q 4
M 1 2
Q 4
M 3 2
Q 1
M 3 1
Q 5
M 4 2
Q 4

Sample Output

Case 1:
2
1
3

Case 2:
1
1
3
1
4


赤裸裸的并查集,一开始TLE了一次,当时是直接查某个元素所属集合里面的元素的个数,扫一遍需要O(n)最坏要O(m*n)。。。不TLE才怪,直接开结构体记录每个集合元素的个数,初始化为1,合并的时候将被合并的集合的元素的个数加到另一个集合里去,查找O(1)

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cctype>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <list>
using namespace std;
typedef struct node
{
	int data,num;
};
node fa[100010];
void Make_set(int n)
{
	for(int i=1;i<=n;i++)
	{
		fa[i].data=i;
		fa[i].num=1;
	}
}
int Find(int x)
{
	if(x!=fa[x].data)
		fa[x].data=Find(fa[x].data);
	return fa[x].data;
}
void Union(int x,int y)
{
	int fx=Find(x);
	int fy=Find(y);
	if(fx==fy)
		return ;
	fa[fy].data=fx;
	fa[fx].num+=fa[fy].num;
}
int main()
{
	int n,m,x,y,T=1;char op;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(T!=1)
			printf("\n");
		getchar();
		printf("Case %d:\n",T++);
		Make_set(n);
		while(m--)
	   {
		 scanf("%c",&op);
		 if(op=='M')
		 {
			scanf("%d%d",&x,&y);
			getchar();
			Union(x,y);
		 }
		 else if(op=='Q')
		 {
			scanf("%d",&x);getchar();
				int ans=fa[Find(x)].num;
			printf("%d\n",ans);
		 }
		}
	}
	return 0;
}


ZOJ 2833-Friendship(并查集+优化),布布扣,bubuko.com

ZOJ 2833-Friendship(并查集+优化)

标签:style   color   os   io   strong   for   ar   art   

原文地址:http://blog.csdn.net/qq_16255321/article/details/38615341

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!