码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1692 Crossed Matchings(DP)

时间:2014-08-16 23:52:01      阅读:560      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   for   ar   

Description

There are two rows of positive integer numbers. We can draw one line segment between any two equal numbers, with values r, if one of them is located in the first row and the other one is located in the second row. We call this line segment an r-matching segment. The following figure shows a 3-matching and a 2-matching segment. 
bubuko.com,布布扣

We want to find the maximum number of matching segments possible to draw for the given input, such that: 
1. Each a-matching segment should cross exactly one b-matching segment, where a != b . 
2. No two matching segments can be drawn from a number. For example, the following matchings are not allowed. 
bubuko.com,布布扣

Write a program to compute the maximum number of matching segments for the input data. Note that this number is always even.

Input

The first line of the input is the number M, which is the number of test cases (1 <= M <= 10). Each test case has three lines. The first line contains N1 and N2, the number of integers on the first and the second row respectively. The next line contains N1 integers which are the numbers on the first row. The third line contains N2 integers which are the numbers on the second row. All numbers are positive integers less than 100.

Output

Output should have one separate line for each test case. The maximum number of matching segments for each test case should be written in one separate line.

Sample Input

3
6 6
1 3 1 3 1 3
3 1 3 1 3 1
4 4
1 1 3 3 
1 1 3 3 
12 11
1 2 3 3 2 4 1 5 1 3 5 10
3 1 2 3 2 4 12 1 5 5 3 

Sample Output

6
0
8

题意:相同数字可以连接但是必须和不同数字的连接交叉。问最大可能性

dp[i][j]表示第一行的前i个和第二行的前j个的最大可能。


#include<limits.h>
using namespace std;
int a[110],b[110];
int dp[110][110];
int n,m,t;

int main()
{
    int k1,k2;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int j=1;j<=m;j++)
            scanf("%d",&b[j]);
        memset(dp,0,sizeof(dp));
        for(int i=2;i<=n;i++)
        {
            for(int j=2;j<=m;j++)
            {
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);//相等时可达到的dp[i][j]的状态的最大值
                if(a[i]!=b[j])
                {
                    for(k1=i;k1>=1;k1--)
                    {
                        if(b[j]==a[k1])
                            break;
                    }
                    for(k2=j;k2>=1;k2--)
                    {
                        if(a[i]==b[k2])
                            break;
                    }
                    if(k1&&k2)
                        dp[i][j]=max(dp[i][j],dp[k1-1][k2-1]+2);//更新dp[i][j]
                }
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}


POJ 1692 Crossed Matchings(DP),布布扣,bubuko.com

POJ 1692 Crossed Matchings(DP)

标签:des   style   http   color   os   io   for   ar   

原文地址:http://blog.csdn.net/u013582254/article/details/38621699

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!