码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 2913 Bus Pass (BFS)

时间:2014-08-17 08:07:21      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   color   os   io   strong   for   

Bus Pass

Time Limit: 5 Seconds      Memory Limit: 32768 KB

You travel a lot by bus and the costs of all the seperate tickets are starting to add up.

Therefore you want to see if it might be advantageous for you to buy a bus pass.

The way the bus system works in your country (and also in the Netherlands) is as follows:

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:

 

bubuko.com,布布扣

Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!

 

Input

On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.

nz lines starting with two integers idi (1 <= idi <= 9 999) and mzi (1 <= mzi <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mzi integers: the numbers of the adjacent zones.

nr lines starting with one integer mri (1 <= mri <= 20), indicating the number of zones the ith bus trip visits, followed by mri integers: the numbers of the zones through which the bus passes in the order in which they are visited.

All zones are connected, either directly or via other zones.

Output

For each test case:

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.

Sample Input

1
17 2
7400 6 7401 7402 7403 7404 7405 7406
7401 6 7412 7402 7400 7406 7410 7411
7402 5 7412 7403 7400 7401 7411
7403 6 7413 7414 7404 7400 7402 7412
7404 5 7403 7414 7415 7405 7400
7405 6 7404 7415 7407 7408 7406 7400
7406 7 7400 7405 7407 7408 7409 7410 7401
7407 4 7408 7406 7405 7415
7408 4 7409 7406 7405 7407
7409 3 7410 7406 7408
7410 4 7411 7401 7406 7409
7411 5 7416 7412 7402 7401 7410
7412 6 7416 7411 7401 7402 7403 7413
7413 3 7412 7403 7414
7414 3 7413 7403 7404
7415 3 7404 7405 7407
7416 2 7411 7412
5 7409 7408 7407 7405 7415
6 7415 7404 7414 7413 7412 7416

Sample Output

4 7400

 

 

        这道题自己做了几天吧,后面问了别人教了我一个思路,居然是和正确答案相反的思路,结果可想而知。不过也听不错的,加深了我对这道题的理解吧。后面就到网上看了别人的解题思路和代码。仿写了一下。

       注意:memset这个函数对数组进行-1赋值的话,理论上是可以的,但在这里对Threshold1进行赋值提交却错了,要用for来赋值。以后要对memset这个函数小心啊。

       题目意思:就是要你找到一些点当中距离每个公交站的阀值尽量小点,并输出那个点聚公交站最大的阀值。

       解题思路:就是找到每个公交线上的点到各个点的最小距离,然后用它来跟新每个点的阀值(当然是取最大的),然后再遍历整个阀值,找到最小的,就OK了。

 

#include <stdio.h>
#include <string.h>
#include <queue>
#define MAXN 10000
#define INF 0x3f3f3f3f
using namespace std;

int Edge[MAXN][10], mz[MAXN];
int Threshold1[MAXN], Threshold2[MAXN];    //Threshold1用来存储阀值,Threshold2则用来每个更新

void BFS(int id)
{
    int top;
    for(int i = 0; i<=MAXN; i++)
        Threshold2[i] = INF;
    queue <int> Q;
    Threshold2[id] = 1;
    Q.push(id);

    while(!Q.empty())
    {
        top = Q.front();     Q.pop();
        for(int i = 0; i<mz[top]; i++)
        {
            if(Threshold2[ Edge[top][i] ] > Threshold2[top]+1)   //找到线上的点到各个点的最小阀值
            {
                Threshold2[ Edge[top][i] ] = Threshold2[top]+1;
                Q.push(Edge[top][i]);
            }
        }
    }

    for(int i = 0; i<=MAXN; i++)    //更新每个点的最大阀值
    {
        if(Threshold1[i] < Threshold2[i] && Threshold2[i] != INF)
        {
            Threshold1[i] = Threshold2[i];
        }
    }
}

int main()
{
    int T;
    int x, y;
    int nz, nr, mr, id;
    scanf("%d", &T);
    while(T--)
    {

        for(int i = 0; i<=MAXN; i++)
            Threshold1[i] = -1;
        scanf("%d%d", &nz, &nr);
        for(int i = 0; i<nz; i++)
        {
            scanf("%d", &id);
            scanf("%d", &mz[id]);
            for(int j = 0; j<mz[id]; j++)
            {
                scanf("%d", &Edge[id][j]);
            }
        }
        for(int i = 0; i<nr; i++)
        {
            scanf("%d", &mr);
            for(int j = 0; j<mr; j++)
            {
                scanf("%d", &id);
                BFS(id);
            }
        }

        x = INF;
        for(int i = 0; i<=MAXN; i++)     //查找最小阀值的点
        {
            if(x > Threshold1[i] && Threshold1[i] != -1)
            {
                x = Threshold1[i];
                y = i;
            }
        }

        printf("%d %d\n", x, y);

    }

    return 0;
}

 

zoj 2913 Bus Pass (BFS),布布扣,bubuko.com

zoj 2913 Bus Pass (BFS)

标签:style   blog   http   color   os   io   strong   for   

原文地址:http://www.cnblogs.com/fengxmx/p/3917373.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!