码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1284 钱币兑换问题

时间:2016-12-06 13:35:53      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:int   ane   bsp   bottom   硬币   input   cep   can   tor   

钱币兑换问题

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9699    Accepted Submission(s): 5898


Problem Description
在一个国家仅有1分,2分,3分硬币,将钱N兑换成硬币有很多种兑法。请你编程序计算出共有多少种兑法。
 

 

Input
每行只有一个正整数N,N小于32768。
 

 

Output
对应每个输入,输出兑换方法数。
 

 

Sample Input
2934 12553
 

 

Sample Output
718831 13137761
 

 

完全背包。只是统计方案数。

dp[i]代表 组成i的方法数。那么 dp[i]可由dp[i-1],dp[i-2],dp[i-3]转移过来...

/* ***********************************************
Author        :guanjun
Created Time  :2016/12/6 11:36:45
File Name     :hdu1284.cpp
************************************************ */
#include <bits/stdc++.h>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
priority_queue<int,vector<int>,greater<int> >pq;
struct Node{
    int x,y;
};
struct cmp{
    bool operator()(Node a,Node b){
        if(a.x==b.x) return a.y> b.y;
        return a.x>b.x;
    }
};

bool cmp(int a,int b){
    return a>b;
}
int dp[40000];
int main()
{
    #ifndef ONLINE_JUDGE
    //freopen("in.txt","r",stdin);
    #endif
    //freopen("out.txt","w",stdout);
    int n;
    dp[0]=1;
    for(int i=1;i<=3;i++){
        for(int j=i;j<=36000;j++)
            dp[j]+=dp[j-i];
    }
    while(~scanf("%d",&n)){
        printf("%d\n",dp[n]);
    }
    return 0;
}

 

HDU 1284 钱币兑换问题

标签:int   ane   bsp   bottom   硬币   input   cep   can   tor   

原文地址:http://www.cnblogs.com/pk28/p/6137002.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!