码迷,mamicode.com
首页 > 其他好文 > 详细

Constructing Roads(最小生成树)

时间:2016-12-07 23:42:45      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:from   should   end   miss   ini   val   生成树   iss   ++   

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 274 Accepted Submission(s): 172
 
Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 
Sample Output
179
 
 
Source
kicc
 
Recommend
Eddy
 
#include<bits/stdc++.h>
#define N 110
using namespace std;
struct node
{
    int u,v,val;
    node(){}
    node(int a,int b,int c)
    {
        u=a;
        v=b;
        val=c;
    }
    bool operator <(const node &a) const
    {
        return val<a.val;
    }
};
vector<node>edge;
int n;
int bin[N];
int findx(int x)
{
    while(x!=bin[x])
    {
        x=bin[x];
    }
    return x;
}
void init()
{
    for(int i=0;i<=n;i++)
        bin[i]=i;
}
int val;
int x,y,t;
int main()
{
    //freopen("C:\\Users\\acer\\Desktop\\in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF)
    {
        init();
        edge.clear();
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&val);
                if(i>j)
                    edge.push_back(node(i,j,val));
            }
        }
        sort(edge.begin(),edge.end());
        long long cur=0;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d",&x,&y);
            bin[findx(y)]=findx(x);
        }
        for(int i=0;i<edge.size();i++)
        {
            int fx=findx(edge[i].u);
            int fy=findx(edge[i].v);
            if(fx!=fy)
            {
                bin[fy]=fx;
                cur+=edge[i].val;
                //cout<<cur<<endl;
            }
        }
        printf("%lld\n",cur);
    }
    return 0;
}

 

Constructing Roads(最小生成树)

标签:from   should   end   miss   ini   val   生成树   iss   ++   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/6142979.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!