码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1564 Play a game

时间:2014-05-08 15:41:33      阅读:294      评论:0      收藏:0      [点我收藏+]

标签:hdu   1564   巴什博弈   

Play a game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1297    Accepted Submission(s): 1056


Problem Description
New Year is Coming! 
ailyanlu is very happy today! and he is playing a chessboard game with 8600. 
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can‘t make a move will lose the game. If both play perfectly, who will win the game?
 

Input
The input is a sequence of positive integers each in a separate line. 
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.
 

Output
Output the winner ("8600" or "ailyanlu") for each input line except the last zero. 
No other characters should be inserted in the output.
 

Sample Input
2 0
 

Sample Output
8600
 

题意:给定一个n*n的表格,在一个角上放入一块石头,然后两个人轮流移动石头,只能水平和竖直移动石子,而且不能移到已经访问的格子,最后没法移动的玩家为输者。现在输入任意的n输出谁输谁胜。这个随便画两个就能很容易的推算出胜负。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <climits>

using namespace std;

int a,b;

int main(){
    //freopen("in.txt","r",stdin);
    //(author : CSDN iaccepted)
	int n;
	while(scanf("%d",&n) && n){
		if(n&1){
			printf("ailyanlu\n");
		}else{
			printf("8600\n");
		}
	}
    return 0;
}



HDU 1564 Play a game,布布扣,bubuko.com

HDU 1564 Play a game

标签:hdu   1564   巴什博弈   

原文地址:http://blog.csdn.net/iaccepted/article/details/25304277

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!